Machine Limits not showing in Linuxcnc 2.8.4

More
15 May 2023 18:08 #271411 by kajukcnc
Hi,

I'm in the process switching from 2.7.x to 2.8.4 and encounered a weird issue. In the Preview window machine limits (Show Machine Limits) are not shown unless I toggle off 'Show Program' and 'Show Program Rapids'. Behaviour is the same in both Debian 10 Live booted from a USB and if I do a full installtion. I tested it on two PCs (one with dedicated Radeon card and one with built-in video) and the result is the same.
When booting back into 2.7.x the machine limits are properly shown regardles of other 'Show ...' toggles state.

Any ideas?

Thank you!
Dmitri

Please Log in or Create an account to join the conversation.

More
17 May 2023 12:01 - 17 May 2023 12:02 #271535 by kajukcnc
I googled a lot to see if anyone reported the same issue and could not find anything. Seems like I'm the only one with this issue.
Last edit: 17 May 2023 12:02 by kajukcnc.

Please Log in or Create an account to join the conversation.

More
18 May 2023 05:23 #271592 by cmorley
I have this/similar problem on one test system using Mint.
I'll have to see if your 'work around' is the same.

Please Log in or Create an account to join the conversation.

More
10 Oct 2023 12:57 #282683 by Bas Cilyco
Hi,
I have the same problem with Linuxcnc 2.8.4 not showing the machine limits. I have also installed a Raspberry Pi and the problem does not exist there. No solution found, so I reinstalled Linuxcnc 2.7.14.

Please Log in or Create an account to join the conversation.

More
10 Oct 2023 18:48 #282695 by cmorley
In 2.9 there was a change to address this problem.we changed the dotted lines to solid lines and tgatcseemed to work.
Maybe we need to back port it.

Please Log in or Create an account to join the conversation.

More
05 Jan 2024 20:42 #289899 by kajukcnc
Upgraded to 2.9.2 and machine limits are back. Thank you!

Please Log in or Create an account to join the conversation.

Time to create page: 0.115 seconds
Powered by Kunena Forum