I cannot Un-Emergancy Stop [X] or Press Power [ | ] in Linux CNC

More
10 May 2018 03:05 - 10 May 2018 05:32 #110486 by BrendaEM
Hi,

I cannot seem to un-press LinuxCNC (In Axis GUI) screen Emergency Stop [X] to turn on screen Power Button [ | ] to start the machine for manual control. I tried pressing [F1] and [F2] quite a bit, with no change. The limit switches work, and are not in a tripped state when I am trying to start it.

I suspect that it's the estop config in the .hal is holding it back.
I've seen threads on estop hal settings, but it's really hard to know when the example needs correction and it's not quite what I want to do.

My setup is a parallel port isolator card. Tempoarily, I just have a wire jumping the terminals p13 to GND to simulate a NC switch.

What I want to do (in the final setup) is use a hardware switch to do an softer emergency-stop stopping LinuxCNC/Axis.
I have not need to send any signals out to hardware--only to tell the GUI to flip the GUI Estop, and stop banging out additional steps.

(I also have a hardware real e-stop, which opens a relay killing the power to the drivers and (future) spindle, yet I want to use a soft-emergency switch, with the hardware the relay switch if all else goes wrong.)

According to the hall utility, the signal is reporting FALSE. Actually, I tried it both ways. The board is doing its job reading the...um...wire bridge.

I suspect I have something wrong with the .hal. The estop section was initially prepared by stepconf. I changed a name, but in two places, which changed nothing, as well.
I thought the problem might be that I wasn't sending the signal out to any pin in the 2nd line. I tried commenting it out, but there was no change, either.

These are the current estop-lines:
net estop-in <= parport.0.pin-13-in

(skipping further down...)

net estop-out <= iocontrol.0.user-enable-out
net estop-in => iocontrol.0.emc-enable-in

[My setup is otherwise strange because I have step-up step-down drivers, but I don't think that that's the problem, because I can't even disengauge the screen Emergancy Stop [X] button, yet.
REF: forum.linuxcnc.org/16-stepconf-wizard/34...tion?start=10#110484 ]

Thanks for reading this far : )
Brenda

Ref:
www.forum.linuxcnc.org/forum/21-axis/293...machine-power-toggle
www.forum.linuxcnc.org/47-hal-examples/25861-external-e-stop
www.forum.linuxcnc.org/47-hal-examples/28096-estop-latch
Attachments:
Last edit: 10 May 2018 05:32 by BrendaEM.

Please Log in or Create an account to join the conversation.

More
10 May 2018 13:09 #110508 by Todd Zuercher
The pin " iocontrol.0.emc-enable-in" needs to be driven true for the machine to come out of E-stop.

Please Log in or Create an account to join the conversation.

More
10 May 2018 17:37 #110528 by BrendaEM

Please Log in or Create an account to join the conversation.

More
01 Jun 2019 08:23 #135550 by vsjadhav
I got the same problem.
What does it mean by "needs to be driven true"
Is it related to changes in .ini
Or
It's about hardware must be connected

Please Log in or Create an account to join the conversation.

More
01 Jun 2019 11:43 #135557 by bevins

vsjadhav wrote: I got the same problem.
What does it mean by "needs to be driven true"
Is it related to changes in .ini
Or
It's about hardware must be connected


Put this in your hal file.
loadrt estop_latch
addf estop-latch.0 servo-thread
net estop-loopout iocontrol.0.emc-enable-in <= estop-latch.0.ok-out
net estop-loopin iocontrol.0.user-enable-out => estop-latch.0.ok-in
net estop-reset iocontrol.0.user-request-enable => estop-latch.0.reset
net remote-estop estop-latch.0.fault-in <=  <Your input goes here>

Please Log in or Create an account to join the conversation.

Time to create page: 0.131 seconds
Powered by Kunena Forum