Disable/increase following error during hominh

More
17 Oct 2021 15:45 #223393 by kimachren
Is it possible to disable or change the following error during homing? The X-slide on my lathe is set up with two inductive sensors as limit switches. Both sensors are also wired to the servo drive's R-/L-Inhibit inputs, so the motor stops when hitting a switch, no matter what. The problem comes when I try to home on the limit+ sensor. The drive sometimes stops the motor before linuxcnc gets the signal and it throws a following error. 
Only other way to solve this that I can think of, is to somehow disable the Inhibit input on the drive.

Please Log in or Create an account to join the conversation.

More
17 Oct 2021 20:12 #223413 by tommylight
That should normally work as is if the wiring is OK and if the drives do not fault when any of the switches is triggered, they should just inhibit the motion on one direction, not both.
For testing:
change the home_latch_velocity to negative or positive by adding or removing a -
same for home_final_velocity
if any of those are not correct the homing procedure will fail.

Please Log in or Create an account to join the conversation.

More
17 Oct 2021 21:47 #223417 by rodw
I think if the motor is going to be disabled by hardware wiring when it hits a shared home/limit switch, you probably need a seperate home switch.

Please Log in or Create an account to join the conversation.

More
17 Oct 2021 22:10 #223421 by tommylight
I did the same thing on the Hurco, it works.
Yaskawa does not disable them, for sure.
Also i am sure having the above mentioned values reversed will just plain halt the machine, and having them reversed is always easy, depending on the info set in PncConf.

Please Log in or Create an account to join the conversation.

More
18 Oct 2021 14:27 - 18 Oct 2021 14:31 #223455 by kimachren
The thing is - it work about two of three times, and when it doesn't, I just have to override limit switches, re-enable the system and push Home All again.
The Inhibit signals just prevents the motors from turning any further to that direction. Ie. when R Inhibit is activated, the motor can only turn to L direction.
Last edit: 18 Oct 2021 14:31 by kimachren.

Please Log in or Create an account to join the conversation.

More
18 Oct 2021 14:46 #223460 by tommylight
It will also need to have a small value of
home_offset
so it moves off the switch after homing, usually 2 to 3mm are enough.

Please Log in or Create an account to join the conversation.

More
18 Oct 2021 17:32 #223482 by kimachren
Sorry that I didn't mention it before, but the axis uses index-homing, so when it works, it finds the limit switch and reverses slowly searching for the insex pulse.

Please Log in or Create an account to join the conversation.

More
24 Oct 2021 22:13 #224127 by andypugh

Is it possible to disable or change the following error during homing? 
 

Yes. You could drive the ini.N.f-error pins:
linuxcnc.org/docs/2.8/html/man/man1/milltask.1.html
Using a mux2:
linuxcnc.org/docs/2.8/html/man/man9/mux2.9.html
Controlled by joint.N.homing:
linuxcnc.org/docs/2.8/html/man/man9/motion.9.html

Please Log in or Create an account to join the conversation.

More
29 Oct 2021 13:55 #224650 by kimachren
Thanks Andy

That was exactly what I was looking for. I didn't even realize there were hal oins for the ini.

Please Log in or Create an account to join the conversation.

Time to create page: 0.115 seconds
Powered by Kunena Forum