EMC2 Lathe Tool Changer Question

More
14 Nov 2009 03:36 #1120 by ZARF
I am a new user of EMC2 and wish to use it on a Lathe. The Lathe conversion is mostly done and I am presently working with setting up the axises (successful) but I have a big problem with respect to the tool changer I built. The problem is I designed the tool post to function using the A axis for rotation of the turret and I used Y to lock the turret into position. I used Powerstation for CadCam work and I set up a tool change macro that is embedded into my G code when the G code is written. This set up with respect to the Lathe and tool turret worked flawlessly except the CNC controler software I was using previously had very few active G codes. That is the reason why I decided to use EMC2.

Much to my surprise when I ran my first file a prompt came up and said "Bad Character Y" and depicted Y as the problem. So it is obivous to me that Y and A are not active in the Lathe Gui. Also, you can't see the axises Y and A at the top of the screen. I like the interface of EMC2 and the real time imaging of the ongoing process during machining. I hope that I can be able to have the Lathe interface accept the Y and A commands and I also prefer not to really see them on screen. If I can't get this solved, then the turret is rendered useless. I am hoping that a combination of work in HAL and in the INI file that I may be able to make these active but maintain the GUI as presented.

I went ahead and set up a 4 axis Mill GUI and configured it with the tool changer in mind and it worked ok except the real time viewing isn't correct and I believe some of the active G code is different for the Mill. (I am wanting to use this on a Lathe).


Any help would be greatly appreciated.

Let me rephase, if the above is not clear in respect to my tool changer problem for my lathe. I am using the AXIS Lathe GUI but the G Code interperter filter will not allow me to use G Code with Y and A, it is important to me that these be accepted because my turret will not get the commands it needs for positioning (it is easy and convenient to use the two axises, Y and A, for these command moves). Is there a way for me to get around this problem. I know I can use the 4 axis stepper GUI as it does work but the real time viewing is schematicaly a milling machine and I prefer the single point tool lathe image that the AXIS Lathe GUI has.
Thanks.

Please Log in or Create an account to join the conversation.

More
14 Nov 2009 07:41 #1121 by alex_joni
It might be possible, but not without a recompile of emc2.
So you need to grab the sources, edit them then recompile everything.
Shouldn't be too much of a problem, although for a first time thing it might seem as much.

Another approach would be to use U,V or W instead of Y.
I think those are still active for a lathe, and it only means you have to change one letter in your postprocessor to fix it.

Regards,
Alex

Please Log in or Create an account to join the conversation.

More
15 Nov 2009 18:56 #1133 by ZARF
Thanks Alex for all of your help. I appreciated it and got it going.

Please Log in or Create an account to join the conversation.

More
18 Dec 2009 22:14 #1356 by robh
hi, i was able to get a Y axes to work under a lathe config running axis
if you have the number of axis correct and Y listed in axis section correct i cant see why you should have any problem ether.

it will display the Y but the Home symbol will be in the wrong place the * to show it is homed. it appears where Y should be on a mill setup.
it does have some quirky things running Y through i find so W U V as mentioned should prove to be alot better

im not sure about using A through i have not tried this

but i found using W in Gcode with a Z made some very odd things happen in the display back plot and motion

rob

Please Log in or Create an account to join the conversation.

Moderators: piasdom
Time to create page: 0.082 seconds
Powered by Kunena Forum