Retrofit lathe with ANILAM CRUSADE ML with ATC

More
20 Mar 2024 16:54 #296402 by COFHAL
There are some threads about the ANILAM CRUSADE M controls, but I have not found any information about the CRUSADE ML controls, which are for lathes. When verifying the technical information, the hardware is similar to that used in milling machines, and on that side there is no problem. The problem is that I can't find any technical information about the automatic tool changer, and it doesn't have any identification plate that comes with the lathe I'm trying to retrofit. I sent a photo to see if anyone has any type of technical information about this ATC. 
Attachments:

Please Log in or Create an account to join the conversation.

More
29 Mar 2024 09:31 #297076 by andypugh
Have you managed to work out what the electrical connections are?
Is the TC hydraulic or electric? I can see at least one sensor, which looks like clamp-unclamp sensing?

If you can make it turn, then you can probably work out what the sensors are.

Please Log in or Create an account to join the conversation.

More
29 Mar 2024 16:37 - 29 Mar 2024 17:07 #297122 by COFHAL
 [Thanks for your response, I already found the manufacturer and model. The model is TOE 100 and is manufactured by Baruffaldi. It's electric. I think I can control it with its carousell component. What I don't know is how to add the necessary time pauses, as indicated in the flow chart for the case of motor rotation reversal.

 

This browser does not support PDFs. Please download the PDF to view it: Download PDF

 

This browser does not support PDFs. Please download the PDF to view it: Download PDF


 

This browser does not support PDFs. Please download the PDF to view it: Download PDF


 

This browser does not support PDFs. Please download the PDF to view it: Download PDF


 

This browser does not support PDFs. Please download the PDF to view it: Download PDF

Attachments:
Last edit: 29 Mar 2024 17:07 by COFHAL.

Please Log in or Create an account to join the conversation.

More
29 Mar 2024 20:22 #297140 by andypugh

What I don't know is how to add the necessary time pauses, as indicated in the flow chart for the case of motor rotation reversal.

The "decel-time" pin might be enough? 
github.com/LinuxCNC/linuxcnc/blob/2.9/sr...s/carousel.comp#L125

Please Log in or Create an account to join the conversation.

More
01 Apr 2024 23:04 #297401 by COFHAL
I have a problem with the carousel component on my turret.Initially it changes the first tool without problem. The first photo is when the tool change has not been requested and the carousel indicates that the active tool is

1. 

When the command is given to change change tool, for example M6 T2 G43, the component works as expected, that is, it is activated, it indicates which tool has been selected, the motor is activated depending on which is the shortest path, as shown photo 2. 



When the turret reaches the selected tool position, T2 in this case, the component does what it has to do: "The component will monitor the carousel position and, when the correct position is reached, set the motor-control pins to 0, set "active" to 0 and set "ready" to 1." as shown in photo 3. 

 

The problem is when the order is given to change to another tool, for example T4, the component no longer works, it does not receive the tool and remains as shown in photo 4. The carousel is not enabled, it is not activated, the pins iocontrol does not change the tool that was selected, etc. 

.

I attach the hal file with which I control the turret. I really don't understand the reason why you only receive the first tool, if it is working well for me on another computer. I don't know if it's because it's an older version of the carousel. And the only way to receive another tool is to close LCN.

 

File Attachment:

File Name: Torreta.hal
File Size:3 KB
Attachments:

Please Log in or Create an account to join the conversation.

More
01 Apr 2024 23:36 #297404 by andypugh
This looks like tool 4 is not in the tool table and has no allocated pocket.
It could be other things, but that is my first guess.

I am mainly basing this on *.tool-prep-pocket being zero.

Please Log in or Create an account to join the conversation.

More
02 Apr 2024 00:32 #297407 by COFHAL
No, in the tool table I have 11, this problem happens regardless of the tool that is selected.

Please Log in or Create an account to join the conversation.

More
02 Apr 2024 15:01 #297437 by COFHAL
There is definitely a problem with the new version of the carousel component. I tried to use my lathe that has a turret and in which this component is working without problem and now it does not work, it has the same problem, it only changes the first tool when LCN starts from there on it does not change the tool. I am using version 2.10.0~pre0.3017.gb7ad470576

Please Log in or Create an account to join the conversation.

More
03 Apr 2024 11:25 #297499 by COFHAL
This issue had already been reported here github.com/LinuxCNC/linuxcnc/issues/2726 and apparently it happens with the LCN 2.10 version.

Please Log in or Create an account to join the conversation.

More
03 Apr 2024 16:11 #297512 by COFHAL
The problem is definitely not in the carousel component, the problem is in version 2.10 of LCN. I reinstalled version 2.9.2 and it works fine.

Please Log in or Create an account to join the conversation.

Moderators: piasdom
Time to create page: 0.250 seconds
Powered by Kunena Forum