Newsa 5i25 7i77 Servo estun

More
20 Oct 2019 09:39 #148394 by Artur_1617
Hi
I have problem with mesa 7i77 and servo estun
The servo can moving only to 5000m/min above make error Ferror in ini file is 50....
step dir can moving to 9000m/min
Servo motor can mov 3000rev/min
Puley form motor to ballscrew is 20/32
Ballscrew is 5mm
With this servo can move axis 9375m/min
I tray to low encoder outputs from drive oryginaƂ was 2500ppr lower to 625ppr but problem still exist

Please Log in or Create an account to join the conversation.

More
More
20 Oct 2019 10:35 #148401 by Artur_1617
I make this and to 5000m/min Ferror is 0,002 but past 5000m/min start problem...

Please Log in or Create an account to join the conversation.

More
20 Oct 2019 12:08 #148405 by PCW
Replied by PCW on topic Newsa 5i25 7i77 Servo estun
Can you post your current hal/ini files?

Please Log in or Create an account to join the conversation.

More
21 Oct 2019 08:11 - 21 Oct 2019 09:28 #148448 by Artur_1617
For now I playing with X axis
One more problem what see is encoder from axis A is counting [without any connection to 7i77....

File Attachment:

File Name: Frezarka_2...0-21.ini
File Size:3 KB

File Attachment:

File Name: Frezarka_2...21-2.hal
File Size:13 KB


Attachments:
Last edit: 21 Oct 2019 09:28 by Artur_1617.

Please Log in or Create an account to join the conversation.

More
21 Oct 2019 15:21 #148475 by PCW
Replied by PCW on topic Newsa 5i25 7i77 Servo estun
A couple things that may be an issue:
1. Your max velocity setting is wrong (it should be in mm/second not mm/min)
2. It does not look like FF1 is correct (if the axis moves at 150 mm/s with 10V, FF1 should be ~0.0666)
3. At 3200 counts/mm at 150 mm/s you are close to the maximum 7I77 count rate
when the encoder filter is enabled so you may need to disable the encoder filter

Please Log in or Create an account to join the conversation.

More
21 Oct 2019 15:41 #148476 by Artur_1617
Today tried to see rpm on servo drive and with linux 4800mm/min servo rpm is 1500 half what is posible
Saturday tried with servo encoder output 800 opr (normalny 2500) and in ini file 625ppr but nathing change
Tomorow change ff1 and report

Please Log in or Create an account to join the conversation.

More
21 Oct 2019 15:51 #148477 by PCW
Replied by PCW on topic Newsa 5i25 7i77 Servo estun
Since the input scale did not change the speed bounding, its not likely an encoder issue
Could you plot the analog out at the same time as the following error?
Perhaps there's a analog input setting that needs to be changed on the drive
(or a wiring error of some kind)

Please Log in or Create an account to join the conversation.

More
22 Oct 2019 07:10 #148532 by Artur_1617
I found the problem
In servo drive was Pn300 set to 150rpm with 1V changing to 300 solved the problem.
Only one things is the value was for torque mode and drive is set to speed control mode...
Finaly spedd is setting to 9400mm/m
And FF1 set to 0,063

Thanks for help

Please Log in or Create an account to join the conversation.

Moderators: PCWjmelson
Time to create page: 0.087 seconds
Powered by Kunena Forum