7i76e to Spindle analogic from Cortini mill L300

More
09 Nov 2020 13:19 - 09 Nov 2020 13:39 #188744 by alkabal
Hi all.

I apologize but another time i have some difficulty with spindle analog management with mesa card 7i76e :pinch:

I have do test with separate 12v power supply with config based from my know working lathe spindle file and pid bypassed.
With this setup i can see voltage output from 0 to 12v so i think the mesa card work fine.

The mill L300 spindle controller use a potentiometer P4 (schematics says 10K but measured 11.5K) the controller seem to work fine.

Now i like to connect spindle analog from 7i76e to the controller but i ave many trouble for get it working properly.

Voltage from both side of the potentiometer (removed) connector is something like 15V with potentiometer connected something like 6V

After connection to the mesa card according to shematics forum.linuxcnc.org/27-driver-boards/3191...nection-sheet/unread

I found only something like 1.6v from spindle + to spindle - and 0v from spindle - to spindle out, spindle turn 2500rpm and speed doesn't change using axis gui +/-.

I suspected the current is not enough for mesa spindle and studying schematics i have found a connector with a direct GND and +15v and try with this one and also try with external power supply with not good result.

Connected again the original potentiometer and controller work fine.

I attache controller schematics, i hope this can be helpful for a more advanced electronics fan able to help me. :kiss:

Best regards

ps : i can attach my config but i really suspect some electrical problem more than a config problem.

the final hal linkage are :
net spindle-vel-cmd <= spindle.0.speed-out
net spindle-vel-cmd => [HMOT](CARD0).7i76.0.0.spinout # DEBUG only fore test without pid !!!!!!!!!!!!!


setp [HMOT](CARD0).7i76.0.0.spinout-minlim 0
setp [HMOT](CARD0).7i76.0.0.spinout-maxlim 3900
setp [HMOT](CARD0).7i76.0.0.spinout-scalemax 3900
Attachments:
Last edit: 09 Nov 2020 13:39 by alkabal.

Please Log in or Create an account to join the conversation.

More
09 Nov 2020 13:29 - 09 Nov 2020 13:40 #188746 by alkabal
Some detail about schematics

on my unit potentiometer P2 is swapped with Resistor P25 and same things for P3 R26

8 pin 555-IC1 is replaced with HCF4538BE


Maybee this is something due to very old capacitor.
Attachments:
Last edit: 09 Nov 2020 13:40 by alkabal.

Please Log in or Create an account to join the conversation.

More
09 Nov 2020 15:16 #188758 by PCW
Sounds like you may need an external supply but I think it needs to be totally isolated
The following user(s) said Thank You: alkabal

Please Log in or Create an account to join the conversation.

More
09 Nov 2020 16:06 - 09 Nov 2020 16:06 #188759 by alkabal
Thanks for reply

You mean use a standard wall mount 220v to 12v 1.5A can be ok if they are infinite resistance from dc line to 220v line ?

I have try with this one but do not work fine, I retry this later

I have think something, the controller possibly need to add a 10k resistor in place of potentiometer P4 connected to P2 P3 ?

I’m open to all suggestions because I have do many different test

I can order something like spin1x or 7I83 or homanndesigns.com/index.php?main_page=pr...ath=1&products_id=25

Br
Last edit: 09 Nov 2020 16:06 by alkabal.

Please Log in or Create an account to join the conversation.

More
09 Nov 2020 19:57 #188788 by alkabal
Well i have do some other test

The setup that seem to work fine is :

add a 10K resistor in place or original potentiometer +/-
connect the potentiometer "gnd" and external 12V gnd to mesa spindle -
externl 12V to mesa spindle +
and off course mesa spindle sig to variable input for controller

It is something understandable ? without the 10K work very bad

Please Log in or Create an account to join the conversation.

More
09 Nov 2020 20:08 #188789 by PCW
Yes, the potentiometer resistance is probably part of the circuit
unlike a normal VFD which just has a pure 0-10V voltage control input
The following user(s) said Thank You: alkabal

Please Log in or Create an account to join the conversation.

More
09 Nov 2020 20:47 #188802 by alkabal
Many thanks for confirmation !

After several test and restoring PID spindle work really fine
This controler have a encoder feedback and with correct config scaling the PID is not fully needed with the mesa spindle management, i'm very happy !

Now it's time for manage to have a delay, or a speed check before changing spindle direction with a 2rt relay, i'm really affraid about that (killed a kbmg lathe controller)

Before that i add a delay before stopping the lathe kbmg for prevent too much brake efficiency. I can easily add the same think but i'm sure something can be better. (comp or near)

Please Log in or Create an account to join the conversation.

Moderators: PCWjmelson
Time to create page: 0.091 seconds
Powered by Kunena Forum