cnc mill joint-2 error limit problem

More
05 Sep 2019 22:58 #144286 by jamby
Hi
I don't know if this is a question or a whine... My bridgeport clone mill has started kicking out joint 2 limit errors. But there is no limit switch being depressed. Most of these errors show up when Xaxis is moving in the neg direction with no Zaxis input. It started yesterday and I parked it until this morning before digging into the issue. I have tested all the Zaxis limit switches with a Volt Meter and all appear to be working correctly then I tested the wiring loop running from the servo box out to the switches and again everything looks good. So checked the continuity from the 5i25 post to the wire in the servo box with no problems.
So I buttoned it all up and ran the same program that was running when it first appeared. After 5 dry runs I felt confident enough to cut some mdf. But in the near the end of the program while cutting a 5/8 hole it errored out again with Zaxis limit. So I tried dry runs again and again no problem so I ran the program again stepping down to full depth (1/4) in to steps and it completed with no errors. Running the next program I move down the Xaxis 9 inches and ran this second program and while moving Xaxis in the neg direction it errored out again....... So I dry ran it with the router and the vacuum running for 3 passes. Ok so on to cutting the part it completed the 4 holes it generated and started the profile across the back down the right side then across the front in the Xaxis negative direction and Boom Z limit error. So reenable and (run from here) on the same line and again error and again. Well there were some 12+ errors trying to get that 6 inch long Xaxis cut complete but as soon as it ended and Yaxis went back to the original start point no more errors.
I've stopped to think about what could be causing this error but I am out of ideas.

If this error would occur while dry running I would jumper across the wires in the servo box and see if that showed any change. I don't like doing anything with a machine without limit switches.

Thanks
Jim

Please Log in or Create an account to join the conversation.

More
05 Sep 2019 23:46 #144297 by andypugh
I tend to run limit switches through a debounce HAL component. A few mS delay in stopping at the switch is unlikely to be a big problem, and nuisance tripping can be.

If you are running a base thread then you can over-sample by 100 or so and still see no delay as the limits are acted on in the servo thread.

With only a servo thread you probably don't want more than 5 samples.

Please Log in or Create an account to join the conversation.

More
06 Sep 2019 01:28 #144304 by jamby
Andy

Uhh errr I am a very old amateur with linuxcnc so all I can say is this is defined in my hal file as
# --- BOTH-X ---
net both-x <= hm2_5i25.0.7i77.0.0.input-15-not

# --- BOTH-Y ---
net both-y <= hm2_5i25.0.7i77.0.0.input-14-not

# --- BOTH-Z ---
net both-z <= hm2_5i25.0.7i77.0.0.input-13-not

At least that's what I think is controlling the Zaxis limits.

Thanks
Jim

Please Log in or Create an account to join the conversation.

More
06 Sep 2019 02:48 #144307 by PCW
Noise is not likely an issue with a 7I77 input (especially at 24V) but a bad switch or intermittent switch wiring could cause this issue.

Since you are using the xxxx-not inputs it means you are using NC switches so any, even very short open connection would cause this issue. I would wiggle wires and tap on the limit switch with LinuxCNC running to see if you can trigger an on-limit fault.

Please Log in or Create an account to join the conversation.

More
06 Sep 2019 06:16 - 06 Sep 2019 06:21 #144323 by pl7i92
it seams a broken or loose wirer
likly broken as it moves to Wirer chanins i guess

can you give us the HAL section of Joint2 Axis Z

you dont need to connect to limit only to REF
then see if error is gone

we use here always limit 0,5mm beond the switch setup
so as Z is almost top max
[AXIS_Z]
MIN_LIMIT = -320
MAX_LIMIT = 0.5

[JOINT_2]
TYPE = LINEAR
HOME = -5.0
FERROR = 5
MIN_FERROR = 0.05
MAX_VELOCITY = 120
MAX_ACCELERATION = 450.0
STEPGEN_MAXACCEL = 550.0
# these are in nanoseconds
DIRSETUP = 8000
DIRHOLD = 5000
STEPLEN = 2800
STEPSPACE = 2800
STEP_SCALE = 100.000
MIN_LIMIT = -320
MAX_LIMIT = 0.5
HOME_OFFSET = 0.000000
HOME_SEARCH_VEL = 8.0
HOME_LATCH_VEL = 2.0
HOME_FINAL_VEL = 8.0
HOME_SEQUENCE = 0
Last edit: 06 Sep 2019 06:21 by pl7i92. Reason: more info

Please Log in or Create an account to join the conversation.

More
06 Sep 2019 22:51 #144428 by jamby
Andy, PCW, pl7i92

Well its looking like I found the bad limit switch, Zaxis minus limit with it jumpered out of the circuit there were no errors. I tried cutting all the switches out first and that showed it must be one of them. It was the second one I tested that ran error free. Odd that it only occurred when cutting but it must be the high vibration because poking the switches and wiring showed nothing.
So now the Great Switch hunt starts. I bought two when I added one for the up limit with the router head mounted and lord knows where that other one went.

Thanks to you all
Jim

Please Log in or Create an account to join the conversation.

More
07 Sep 2019 15:13 - 07 Sep 2019 15:17 #144481 by pl7i92
you will find it
you only need the TOP switch the rest will do the softlimits
linuxcnc will not pass them
and if you loose so many steps that triggers you may already be in big trouble

in hal you need to get rid of the limits
# ---setup home / limit switch signals Joint2 ZAXIS---
net both-z => joint.2.home-sw-in
# net z-neg-limit => joint.2.neg-lim-sw-in
# net z-pos-limit => joint.2.pos-lim-sw-in

where signal is your net both-z <= hm2_5i25.0.7i77.0.0.input-13-not
Last edit: 07 Sep 2019 15:17 by pl7i92. Reason: hal

Please Log in or Create an account to join the conversation.

Moderators: cncbasher
Time to create page: 0.093 seconds
Powered by Kunena Forum