Arc issues with eithe lcnc or fusion 360

More
16 Jun 2016 06:18 - 16 Jun 2016 06:19 #76132 by JR1050
I am having a similar issues to another post with Fusion 360 and my lcnc equipped lathe. I get the alarm/ warning in the picture, which I nicked from the other post .When I switched from I/k arc centers to "r" , the issues went away. I tried all three fanucish posts with the same results. I'm not using TNC .Suggestions. Thanks.


Attachments:
Last edit: 16 Jun 2016 06:19 by JR1050.

Please Log in or Create an account to join the conversation.

More
16 Jun 2016 12:20 #76157 by Todd Zuercher
Can we see the g-code that is causing the error?

Please Log in or Create an account to join the conversation.

More
16 Jun 2016 18:37 #76181 by JR1050
this works

%
(1001)
M6T1(80 DEG TURN TOOL)
G18G40
G95G96S280M3D1800
G0G90G54Z0
G43X4.7 Z0.0562M8H1
G0 Z0.035
X4.6301
G1 X4.5255 F0.02
X4.4548 Z-0.0004
G18 G3 X4.48 Z-0.0356 R0.0556
G1 Z-0.9156
X4.4992
X4.5699 Z-0.8803
G0 Z0.0308
X4.5063
G1 X4.4216 F0.02
X4.3508 Z-0.0046
X4.3908 Z-0.0246 F0.004
G3 X4.4 Z-0.0356 R0.0156
G1 Z-0.9156
X4.4707 Z-0.8803 F0.02
X4.56
G0 X4.7
Z.05
G0G49Z0X0




this gets an arc endpoint error at the line with G18 G3 similar to the screen shot above. Every place in the program there is a chamfer, , the software generates arcs and errors with I/K radius designations.
(1001)
M6T1(80 DEG TURN TOOL)
G18G40
G95G96S280M3D1800
G0G90G54Z0
G43X4.7 Z0.0562M8H1
G0 Z0.035
X4.6301
G1 X4.5255 F0.02
X4.4548 Z-0.0004
G18 G3 X4.48 Z-0.0356 I-0.0861 K-0.0705
G1 Z-0.9156
X4.4992
X4.5699 Z-0.8803
G0 Z0.0308
X4.5063
G1 X4.4216 F0.02
X4.3508 Z-0.0046
X4.3908 Z-0.0246 F0.004
G3 X4.4 Z-0.0356 I-0.0221 K-0.0221
G1 Z-0.9156
X4.4707 Z-0.8803 F0.02
X4.56
G0 X4.7
Z0.



I have not had this issue with other cam systems, so i suspect the post in Fusion. Thanks ahead of time
Its hot in Fl today......

Please Log in or Create an account to join the conversation.

Moderators: Skullworks
Time to create page: 0.093 seconds
Powered by Kunena Forum