7i76E - Starting

More
04 Nov 2018 01:37 #119906 by MarcoGaspar
Replied by MarcoGaspar on topic 7i76E - Starting

PCW wrote:

Done that, and its the same...


swaped to old chinese db25 and works ok.... but on 7i76e not


Can you include you current hal/ini files?

Attachments:

Please Log in or Create an account to join the conversation.

More
04 Nov 2018 01:39 #119907 by PCW
Replied by PCW on topic 7i76E - Starting
looks like you only changed 1 axis...

Please Log in or Create an account to join the conversation.

More
04 Nov 2018 01:43 #119908 by MarcoGaspar
Replied by MarcoGaspar on topic 7i76E - Starting
yes i only have X axis connected to mesa

Please Log in or Create an account to join the conversation.

More
04 Nov 2018 01:59 #119909 by PCW
Replied by PCW on topic 7i76E - Starting
Looks like that should work, is it possible you have the step polarity wrong?
The following user(s) said Thank You: MarcoGaspar

Please Log in or Create an account to join the conversation.

More
04 Nov 2018 11:56 #119927 by MarcoGaspar
Replied by MarcoGaspar on topic 7i76E - Starting

PCW wrote: Looks like that should work, is it possible you have the step polarity wrong?


All working it was a accidental driver dipswitch touch when changing the wires.

Thanks :D :D :D

Please Log in or Create an account to join the conversation.

More
04 Nov 2018 12:34 #119928 by MarcoGaspar
Replied by MarcoGaspar on topic 7i76E - Starting
i have longs stepper motor 23hS9430B with DM860A drivers i have some resonance noise at lower feedrate is any parameter to eliminate or reduce that?

Please Log in or Create an account to join the conversation.

More
04 Nov 2018 14:52 #119931 by PCW
Replied by PCW on topic 7i76E - Starting
You can often reduce resonance issues by raising the drives microstep ratio
(and adjusting LinuxCNCs scale parameters in the ini file accordingly)

Please Log in or Create an account to join the conversation.

More
04 Nov 2018 20:30 #119937 by rodw
Replied by rodw on topic 7i76E - Starting
Your drives should handle microstepping easilly with that driver. If you haven't already, you should be using some kind of reduction drive on your motor. They are fairly easy to make with a timing belt. See this thread for more info.
forum.linuxcnc.org/30-cnc-machines/31509...pinion-drive?start=0
I ended up with a 3:1 drive on my Z axis after people here told me I would have troubles with direct drive.

Please Log in or Create an account to join the conversation.

More
05 Nov 2018 15:27 #119993 by andypugh
Replied by andypugh on topic 7i76E - Starting

MarcoGaspar wrote:
- Start PNCCONF and when i try to test axis i get error (IMG_20181103_212410.jpg)


That was a bug. Fixed here:
github.com/LinuxCNC/linuxcnc/commit/f203...b766df37a81b747caf48

The fix won't be in a released version quite yet, but you can hand-edit /usr/bin/pncconf, (no need to recompile)

Please Log in or Create an account to join the conversation.

Moderators: cmorley
Time to create page: 0.106 seconds
Powered by Kunena Forum