Force acis to maximise and homing sequence

More
03 Jan 2019 07:52 #123392 by trilobyte
i am setting up a lathe with a 7I76e. i checked the checkbox "force axis to maximise (or something like that)
but this isn't working and if i load the setting again in pncconf the checkbox is unchecked.

then there is another problem. if i set the homeing sequence x axis 1 and z axis 2. this results in 0 and -1 in the ini file?

are these known problems?

Peter

Please Log in or Create an account to join the conversation.

More
03 Jan 2019 09:03 #123393 by cmorley
What version of linuxcnc are you using?
In 2.7 it seemed to work for me.
Other then depending on the window manager AXIS is displayed minimized by default - something that I am not sure pncconf can do anything about.
also I did have to mess with the code to set AXIS to maximum.

How did you set the home sequence?

Chris M

Please Log in or Create an account to join the conversation.

More
03 Jan 2019 10:15 - 03 Jan 2019 10:29 #123401 by trilobyte
i installed the r13 debian stretch image and i'm working with the actual master release.

i have set the homeing sequence in pncconf. i tryed different things. X set to 1, Z set to 2 and at another try i set x to 0 and Z to 1.
both results in an -1 in the ini file

Peter
Last edit: 03 Jan 2019 10:29 by trilobyte.

Please Log in or Create an account to join the conversation.

More
03 Jan 2019 10:24 - 03 Jan 2019 10:27 #123402 by trilobyte
My pnccconf file and the resulting hal and ini:

schaublin125.pncconf
schaublin125.hal
schaublin125.ini

btw: i found a (cosmetic) bug in the settings for the digital outputs. they are names as Digital out 0,1,2,1 instead of 0,1,2,3

peter
Last edit: 03 Jan 2019 10:27 by trilobyte.

Please Log in or Create an account to join the conversation.

More
03 Jan 2019 11:40 #123404 by cmorley
ok I pushed a fix for these to master.
Thanks
Chris M
The following user(s) said Thank You: trilobyte

Please Log in or Create an account to join the conversation.

More
03 Jan 2019 19:32 #123422 by trilobyte
after an apt-get update, apt-get dist-upgrade i openend the config again, now it is working as expected!

tnx!

peter

Please Log in or Create an account to join the conversation.

More
04 Jan 2019 00:24 #123442 by cmorley
Excellent - thanks for the report.
If you want true fullscreen you can uncomment a line in the .axisrc in your home folder.

Chris M

Please Log in or Create an account to join the conversation.

Moderators: cmorley
Time to create page: 0.083 seconds
Powered by Kunena Forum