PNCConf 2.90-pre0-3629g4fb5248dd (~03/03/2021) --- bug? (sorted)

More
03 Mar 2021 20:55 - 04 Mar 2021 07:58 #200940 by robertspark
Could someone please check something for me

Could you simply create a new profile with the PNCConf tool (simple + fast mill) using axis / anything really.

load it and see if it is very slow.

I found that :
[TASK]
TASK = milltask
CYCLE_TIME = 100

was set

I believe
CYCLE_TIME = 0.010

should be the more correct number as it is measured in seconds

(I have done a lot of installs and reinstals from a clean LCNC iso + update to master via buildbot)

I hate calling "bug" but something went wrong for me and LCNC GUI's (I tried a few via pncConf) were very very slow... I thought I'd changed the wrong settings in the bios or something.... then changed Cycle_Time = 0.010 and all is happy now.

{note I had no problems with the QTPlasmaC sim I loaded just to test and headscratch).


I did ask for "Commanded" position and not "actual".... that was the only other chane I did on the GUI / Axis screenset in PNCConf
Last edit: 04 Mar 2021 07:58 by robertspark. Reason: resolved

Please Log in or Create an account to join the conversation.

More
03 Mar 2021 22:47 #200952 by PCW
That's interesting had another customer complain about a similar issue,
must be that pncconf and Axis? GUI don't agree on units

The change to ms was done here

github.com/LinuxCNC/linuxcnc/commit/8f2e...0164df7677d5857f0d8e

Please Log in or Create an account to join the conversation.

More
04 Mar 2021 00:10 #200966 by andypugh
A more instructive commit:
github.com/LinuxCNC/linuxcnc/commit/9bd5...b9f31bad0c6d967654a7

Axis should now make a reasonable choice about whether the number is seconds or mS.

(This is useful when switching GUIs)

Please Log in or Create an account to join the conversation.

More
04 Mar 2021 00:16 #200968 by tommylight
Latest 2.9/Master build, the TASK has it set to 100:

While EMCIO has it set at 0.1
Attachments:

Please Log in or Create an account to join the conversation.

More
04 Mar 2021 02:13 #200981 by cmorley
sorry about that guys - thanks for the hint. should be fixed now.

Chris
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

More
04 Mar 2021 06:37 #200995 by robertspark
thanks all, thought I was going mad (wondering what or how I broke things)

note, I had the same problem when I created a Gmoccapy GUI first with the config, then created an axis and a at dragon screenset with the same Pncconf. file just changing the GUI

I then formatted the drive and put a new lcnc install from buster iso 2.8, upgraded to master via buildbot.

created a new Pncconf with axis first (as axis always worked fine previous) and it was unresponsive too..... then went investigating the hal / ini file settings and found the 100 .... changed it to 0.010 and everything worked fine creating axis, Gmoccapy guis

glad I was able to help as I'm sure it may have confused others.

+ glad someone was able to work out what I was waffling on about and work out the potential problems / where the issue was.
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

More
04 Mar 2021 13:36 #201020 by cmorley
What a mess I made :( unfortunate- we were trying to make it easier to switch between screens. I just didn't read my code closely enough. This affected Stepconf too - fixed as well.
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

Moderators: cmorley
Time to create page: 0.126 seconds
Powered by Kunena Forum