glade-gtk2 crash when adding MDI Action

More
07 Apr 2015 15:58 #57601 by DaBit
DaBit created the topic: glade-gtk2 crash when adding MDI Action
I am trying to create a simple GladeVCP panel with buttons that should trigger O-word subroutines. I did that before on my previous machine which used Ubuntu 10.04/LinuxCNC 2.5 and that was a smooth experience.

Not this time on Wheezy / LinuxCNC master as RIP. When trying to add a 'MDI Action' glade-gtk2 crashes:
(glade-3:16217): GLib-GObject-WARNING **: /build/buildd-glib2.0_2.33.12+really2.32.4-5-i386-eISom6/glib2.0-2.33.12+really2.32.4/./gobject/gtype.c:4206: type id `0' is invalid

(glade-3:16217): GLib-GObject-WARNING **: can't peek value table for type `<invalid>' which is not currently referenced
Segmentation fault
dabit@snsmill:~/linuxcnc/configs/sim.axis$ 

There really isn't much in the panel yet:



I am running glade-gtk2 from a terminal window where I sourced the rip-environment script and gtk2-engines/gtk2-engines-xfce is installed.


Also, I seem to be unable to set the status of a checkbox to 'checked' by default. I can set the 'Active' property to 'yes', but that is ignored.
More
21 Nov 2017 18:26 #102150 by jpa
jpa replied the topic: glade-gtk2 crash when adding MDI Action
I found a workaround that seems to avoid the crash:

1. Select "VCP Action MDI" from left panel
2. Right click widget list in top right and select "Add widget as top level".
More
22 Nov 2017 08:24 #102176 by DaBit
DaBit replied the topic: glade-gtk2 crash when adding MDI Action
Indeed, al those Actions should be at the top level to prevent this.
More
28 Nov 2017 15:47 #102438 by Mech john
Mech john replied the topic: glade-gtk2 crash when adding MDI Action
Is this problem also effecting the probe_screen panel from the russian guy 'verser' it worked great but I upgraded to latest linuxcnc version and now I get strange 'have to be in mdi mode...' error messages when I try to use it. Seems to me it is a glade problem but I have no real experience with this...

cheers, John
More
07 Dec 2017 16:48 #102748 by newbynobi
newbynobi replied the topic: glade-gtk2 crash when adding MDI Action
It is an axis problem!
It is known and will probably be solved soon.

It does work with master and gmoccapy.

Norbert
Moderators: mhaberler
Time to create page: 0.068 seconds
Powered by Kunena Forum