Gladevcp Problem?

More
28 Mar 2017 14:34 #90442 by Todd Zuercher
Todd Zuercher created the topic: Gladevcp Problem?
This morning one of the machine operators ran an update on a machine that had been working fine yesterday.
The machine is an older Lucid install with Linuxcnc 2.7.8.
It looks to me like the problem has something to do with the Gladevcp, but it had been working before. Anyone know what the update might have broken, or how to fix it?
An older version of this config that has a Pyvcp instead of aGladevcp starts and runs fine.

Here is what is spit out when trying to start from the command line:
linuxcnc
LINUXCNC - 2.7.8-70-g94e0c5c
Machine configuration directory is '/home/digital4/linuxcnc/configs/Digital_4g'
Machine configuration file is 'Digital_4w.ini'
Starting LinuxCNC...
Found file(REL): ./Digital_4w.hal
Traceback (most recent call last):
File "/usr/bin/gladevcp", line 45, in <module>
import gladevcp.makepins
File "/usr/lib/pymodules/python2.6/gladevcp/__init__.py", line 5, in <module>
import os,sys,glob,importlib,subprocess
ImportError: No module named importlib
<commandline>:0: waitpid failed gladevcp gladevcp
<commandline>:0: gladevcp exited without becoming ready
Embeded tab command "halcmd loadusr -Wn gladevcp gladevcp -c gladevcp -x 69206176 -u dig4.py dig4.glade" exited with error: 1
Shutting down and cleaning up LinuxCNC...
task: 281 cycles, min=0.000035, max=0.022022, avg=0.009583, 0 latency excursions (> 10x expected cycle time of 0.010000s)
LinuxCNC terminated with an error. You can find more information in the log:
/home/digital4/linuxcnc_debug.txt
and
/home/digital4/linuxcnc_print.txt
as well as in the output of the shell command 'dmesg' and in the terminal
digital4@digital4-cnc:~$
More
28 Mar 2017 15:08 #90446 by andypugh
andypugh replied the topic: Gladevcp Problem?
Have you lost the glade-gtk2 package? (Perhaps updated to GTK3?)
More
28 Mar 2017 15:33 #90448 by dgarrett
dgarrett replied the topic: Gladevcp Problem?

ImportError: No module named importlib


this appears to be due to unavailability of the importlib module in the python version on lucid

the use of importlib was added with the merge of the branch aux_gladevcp_apps that supports
independent applications like NativeCAM

i'll work on a fix that will allow lucid installs to continue without importlib
More
28 Mar 2017 15:56 #90450 by Todd Zuercher
Todd Zuercher replied the topic: Gladevcp Problem?
Could I just force an installation of a previous version of something, to get the machine running again? What? I tried forcing Linuxcnc to 2.7.8.67 and that didn't do it. (I kind of need some the things in my Gladevcp that I could not do with my old Pyvcp.)
More
28 Mar 2017 16:09 #90451 by dgarrett
dgarrett replied the topic: Gladevcp Problem?
I've pushed a fix:
git.linuxcnc.org/gitweb?p=linuxcnc.git;a...aa35024c47832714f29f

Available in git now, buildbot debs usually take a couple of hours
Please test and report.
The following user(s) said Thank You: Todd Zuercher
More
28 Mar 2017 19:30 #90454 by Todd Zuercher
Todd Zuercher replied the topic: Gladevcp Problem?
It works now. (for me at least)
More
05 Apr 2017 16:54 #90937 by Todd Zuercher
Todd Zuercher replied the topic: Gladevcp Problem?
I may have spoken too soon. I am now experiencing random freezes. (Whole computer locks up after 30min-2hours while Linuxcnc is running.)

Installed Wheezy on another partition, and using the same config on the same hardware, it has ran for 2 days without a hiccup.

There may still be bugs there in the Lucid system, unless I have a pending hardware failure.
Moderators: mhaberler
Time to create page: 0.074 seconds
Powered by Kunena Forum