Using Offsetpage Widget?

More
07 Jun 2017 18:20 #94256 by Todd Zuercher
Todd Zuercher created the topic: Using Offsetpage Widget?
I would like to setup a tab in axis using Gladevcp and the offsetpage widget. But I'm having a little trouble making it work.
I was able to get a tab showing the widget but it does not seem to populate the table with the existing offsets.
What is the trick to make it work right?
More
07 Jun 2017 18:57 #94260 by cmorley
cmorley replied the topic: Using Offsetpage Widget?
I'm going to guess that the offset widget is not finding the tooltable from the INI.
Most (all?) of the guis that use it set the file path explicitly.
something like:

offsetpage_widget_name.set_filename("../../../configs/sim/gscreen_custom/sim.var")

While it should work without this - that behavior has not been checked in a long time.

Chris M
More
07 Jun 2017 21:06 #94268 by Todd Zuercher
Todd Zuercher replied the topic: Using Offsetpage Widget?
I'm still not able to figure it out yet.

That line would go in the py file? but I haven't a clue what that file should even look like? (programming is not a strong point for me.)
More
26 Sep 2017 18:13 #99477 by PKM
PKM replied the topic: Using Offsetpage Widget?
Hello,
I can't get offsetpage widget to connect to linuxcnc instance.
It always has this error **** Offsetpage widget ERROR: LINEAR_UNITS not found in INI's TRAJ section
and won't read the offset values.
Anyone has a working example for offsetpage?
More
03 Oct 2017 21:10 #99852 by andypugh
andypugh replied the topic: Using Offsetpage Widget?
Have you tried simply adding a LINEAR_UNITS = to the [TRAJ] section?
More
03 Oct 2017 21:22 #99853 by PKM
PKM replied the topic: Using Offsetpage Widget?
Well that error message popped because I tried using offsetpage from a separate python file and it received no linuxcnc-specific environment variables.
But when I used offsetpage in Axis tab, with [TRAJ] LINEAR_UNITS = mm, it was still in inches.
Only [widget name].set_to_mm() solved the problem.
Moderators: mhaberler
Time to create page: 0.082 seconds
Powered by Kunena Forum