PathPilot on AMD GizmoSphere 1

More
19 Nov 2015 15:01 #65507 by Iron-Man
Iron-Man created the topic: PathPilot on AMD GizmoSphere 1
I am currently in the process of running PathPilot on the AMD GizmoSphere 1 which is "Open Source Hardware" My configuration is a Mesa 6i25 + 7i77. The GizmoSphere is up and running the tormach_lathe.ini and the tormach_lathe_sim.ini files. I attacked the problem by first getting linuxcnc to run my servos and copying the ini and hal files as examples. The 6i25 has been flashed with file 5i25_7i77x2.bit. I was able to get PathPilot running by using this bit file. I believe that my problem is getting the hal file corrected to match my I/O. If PathPilot has the complete Linuxcnc interface then it should not be a problem. Has anyone tried the 7i77 + PathPilot combination? Some of my work is posted here: Denford NovaTurn

PCW_Mesa have you tried PathPilot + 6i25+7i77 ?

Thanks,

Iron-Man
More
19 Nov 2015 15:26 - 19 Nov 2015 15:32 #65509 by cncbasher
cncbasher replied the topic: PathPilot on AMD GizmoSphere 1
theirs a lot of fixed parameters on the pathpilot , but it is just a question of working through them
but the interface is exactly the same as Linuxcnc abeit version 2.6

a 6i25 is the same as a 5i25 only with pci express , and uses the same files
Last Edit: 19 Nov 2015 15:32 by cncbasher.
More
19 Nov 2015 21:24 #65538 by Iron-Man
Iron-Man replied the topic: PathPilot on AMD GizmoSphere 1
Thanks Cncbasher. Do you know if mux16 is part of Linux 2.6?
I have PathPilot running with 7i77 bit file.
I ended up commenting all sections that produced errors in the ini and hal files until I was able to get it to run.
Just need to connect estop and enable pins to the GUI and connect remainder of signals.

Thanks,

Iron-Man
More
20 Nov 2015 00:19 #65552 by andypugh
andypugh replied the topic: PathPilot on AMD GizmoSphere 1

Iron-Man wrote: Thanks Cncbasher. Do you know if mux16 is part of Linux 2.6?


It is.

All the HAL components are documented here: linuxcnc.org/docs/2.7/html/
More
20 Nov 2015 01:53 #65555 by Iron-Man
Iron-Man replied the topic: PathPilot on AMD GizmoSphere 1
Thanks Andy. I know this should be easy but where are the MUX16 modules located?
I get this error "Can't find module 'MUX16'.

Iron-Man
More
20 Nov 2015 04:09 #65559 by Iron-Man
Iron-Man replied the topic: PathPilot on AMD GizmoSphere 1
I was unable to find the mux4 and mux16 modules in PathPilot. it is possible that they are not part of PathPilot? I believe that the mux files have a mux#.ko file extension. If anybody has these files for PathPilot / Linux 2.6? please let me know.
I did manage to get the x and z axis functioning.

Thanks,

Iron-Man
More
20 Nov 2015 05:21 - 20 Nov 2015 05:22 #65560 by Rick G
Rick G replied the topic: PathPilot on AMD GizmoSphere 1
Have you looked for the man page from a terminal?
man mux16
linuxcnc.org/docs/html/hal/components.html

Rick G
Last Edit: 20 Nov 2015 05:22 by Rick G.
More
20 Nov 2015 12:17 #65571 by cncbasher
cncbasher replied the topic: PathPilot on AMD GizmoSphere 1
yes they are part of pathpilot .
remember your using version 2.6.0 ,with pathpilot so look if the format has changed etc
More
20 Nov 2015 15:07 #65573 by andypugh
andypugh replied the topic: PathPilot on AMD GizmoSphere 1

Iron-Man wrote: I get this error "Can't find module 'MUX16'.


The error message will show the exact file and line number where the error occurs.
It would be helpful if you could show us that line.
More
20 Nov 2015 16:37 #65575 by Iron-Man
Iron-Man replied the topic: PathPilot on AMD GizmoSphere 1

andypugh wrote:

Iron-Man wrote: I get this error "Can't find module 'MUX16'.


The error message will show the exact file and line number where the error occurs.
It would be helpful if you could show us that line.


Thanks Andy. I will post later. I did try man mux16, man mux4 and these are not located in PathPilot, unless they have been changed or they are no longer used. I will try loading a older computer with Linuxcnc and see if I can extract the modules directly if possible.

Thanks,

Iron-Man
Time to create page: 0.101 seconds
Powered by Kunena Forum