Installing Master on Debian 9 Error

More
11 Aug 2018 13:07 #115883 by BigJohnT
I'm trying to install master on Debian 9 and I'm getting a key error. This is the steps I"m using.
https://cdimage.debian.org/cdimage/unofficial/non-free/cd-including-firmware/
drill down to the latest version of the nonfree amd64 iso-cd netinst.iso
burn to cd, then boot from the cd, Graphical Install, English, United States,
American English, domain name, don't enter root password, user name/password,
guided use entire disk, all files in one partition, United States, Mate,
SSH Server, standard system utilities, install GRUB Yes,
Debian desktop environment, Mate, SSH server, standard system utilities

sudo nano /etc/lightdm/lightdm.conf
to log in without your user name a password uncomment
and add your user name
autologin-user=john
autologin-user-timeout=0

Open the Synaptic Package Manager
search for linux-image and install linux-image-latest version-rt

reboot the pc
in a terminal type uname -a it should report back PREEMT RT
Linux mesa-eth 4.9.0-7-rt-amd64 #1 SMP PREEMPT RT Debian 4.9.110-3+deb9u1 (2018-08-03) x86_64 GNU/Linux

sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install dirmngr
sudo apt-key adv --keyserver hkp://keys.gnupg.net --recv-key 3cb9fd148f374fef
sudo apt-get install software-properties-common
sudo add-apt-repository "deb http://buildbot.linuxcnc.org/ stretch master-rtpreempt"
sudo apt-get update
sudo apt-get install linuxcnc-uspace

I get this error:
W: GPG error: http://buildbot.linuxcnc.org stretch Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY EF1B07FEE0EE663E
W: The repository 'http://buildbot.linuxcnc.org stretch Release' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.

JT
More
11 Aug 2018 18:28 #115904 by tommylight
I just download Linuxcnc deb from master, the latest version, install gdebi and install Linuxcnc.
it worked every time.
The only difference is i use an RT-preempt kernel i built for a Linux mint with mate.
More
11 Aug 2018 19:30 #115911 by BigJohnT
It installed just fine but I think that the buildbot uses different keys than the manual has so that I think is the error I got.

JT
The following user(s) said Thank You: tommylight
More
12 Aug 2018 09:54 #115949 by BigJohnT
I found out that linuxcnc.org and buildbot.linuxcnc.org have different keys.

JT
More
12 Aug 2018 15:08 #115964 by BigJohnT
Where is that deb located at?

Jeff said I needed both keys and I tried that and that works.

JT
More
12 Aug 2018 20:05 #115980 by tommylight
buildbot.linuxcnc.org/dists/stretch/
There is 2.7 and master there. And scratch.
The following user(s) said Thank You: BigJohnT
More
13 Aug 2018 10:27 #115993 by BigJohnT
I'm really confused now lol, Trying to install pyqt5 and apt-get can find the package. Doing a fresh install this morning.

If you use the deb I assume you don't get any updates?

JT
More
13 Aug 2018 11:22 #115996 by tommylight
Updates for Linuxcnc ? No, i never do except when i explicitly update manually.
More
13 Aug 2018 13:18 #116002 by BigJohnT
I just solved one puzzle there are two locations for dists:
linuxcnc.org/dists/
this repository uses this key and only contains released versions
sudo apt-key adv --keyserver hkp://keys.gnupg.net --recv-key 3cb9fd148f374fef

buildbot.linuxcnc.org/dists/
this repository uses this key and contains master and the current releases
sudo apt-key adv --keyserver hkp://keys.gnupg.net --recv-key E0EE663E

This information needs to be in the Documents...

JT
The following user(s) said Thank You: tommylight
Time to create page: 0.069 seconds
Powered by Kunena Forum