[SOLVED] LinuxCNC on Arch

05 Apr 2021 15:53 - 05 Apr 2021 19:23 #204911 by rajewski
I'm trying to install LinuxCNC 2.8.1 on Arch and have mostly made it.

I've installed the PREEMPT_RT kernel and have successfully compiled linuxcnc.

I mostly followed the linuxcnc-git package from the AUR but modified it to pull the 2.8 branch and added some other 'fixes' needed to get it to compile.

I've tried compiling it for run-in-place, with the following.
 ./configure --with-realtime=uspace \
   --with-python=/usr/bin/python2.7 \
sudo make setuid
source ../scripts/rip-environment

This launches successfully, but when I select axis and click OK it crashes with the following.
LINUXCNC - 2.8.1
Machine configuration directory is '/home/justin/linuxcnc/configs/sim.axis'
Machine configuration file is 'axis.ini'
can't find package Linuxcnc
    while executing
"package require Linuxcnc "
    (file "/home/justin/linuxcnc-git/src/linuxcnc-rt-2.8/lib/hallib/check_config.tcl" line 141)
check_config validation failed
LinuxCNC terminated with an error.  You can find more information in the log:
as well as in the output of the shell command 'dmesg' and in the terminal

The two log files are blank.

I think this is just something wrong with my path?
echo $PATH

I've been able to find a couple mentions of this problem elsewhere but no real solutions to it besides forum.linuxcnc.org/9-installing-linuxcnc...uire-linuxcnc-solved which I don't think is my issue.

I realize installing on Arch isn't supported and it would be simpler to use the image, but if I can get it to work I'd be pretty stoked.
Last edit: 05 Apr 2021 19:23 by rajewski.

Please Log in or Create an account to join the conversation.

05 Apr 2021 15:58 - 05 Apr 2021 19:23 #204912 by rajewski
Replied by rajewski on topic LinuxCNC on Arch
Well I just figured it out.

The path issue is with TCLLIBPATH. Setting it to /home/justin/linuxcnc-git/src/linuxcnc-rt-2.8/tcl made it work as a RIP just fine. (it had another path to the permanent install that probably has some issue)

For anyone else who may run into this issue, I found changing the line
echo "export TCLLIBPATH=$TCLLIBPATH:/usr/lib/tcltk/linuxcnc" > ${pkgname}.sh
echo "export TCLLIBPATH=/usr/lib/tcltk/linuxcnc" > ${pkgname}.sh
in the PKGBUILD file worked. Apparently if TCLLIBPATH is empty then leading with the : caused issues.
Last edit: 05 Apr 2021 19:23 by rajewski. Reason: Added fix for PKGBUILD

Please Log in or Create an account to join the conversation.

Time to create page: 0.063 seconds
Powered by Kunena Forum