Network Fail During Install - LinuxCNC 2.8.2 and Debian 10 Buster

More
25 Jul 2022 06:05 #248221 by jay.perez1
Hi All, 

Attempting to install LinuxCNC 2.8.2 but it's failing when it tries to configure the network. It appears to recognize the on-board network device and says it's configuring DHCPv6 but it hangs up at that point. I've left it there overnight but it never continues. (It does not recognize the TP-Link USB wireless adapter that I plugged in during the installation.)

I've tried to install it on two different computers and using two different USB drives with fresh downloads from the LinuxCNC site. Still no joy.

As a test I also installed the previous version of LinuxCNC (2.7 Wheezy) and it successfully installed and configured both the on-board and wireless networks without any issues.

Spent a lot of time searching the forums and Internet and trying different things to resolve it without success.

Found a post that mentioned my router so I enabled the IPv6 protocol which seemed to help some but not enough to get past the hung screen. (There was not an option to update the firmware as this is a Spectrum modem/router.) 

Decided to continue the installation without setting up the network. This allowed me to finish the install.

The nm-tray was available but there were no networks listed.

Tried to do things like install Network Manager using Synaptic but no luck. Found a posting that described manually entering the on-board NIC in the network interfaces file and this worked, somewhat ...

I could now open Firefox and go to sites like Google and this forum but would often get an error message if I clicked on a link to take me to another site or posting saying the site was not found.

Very frustrating as I have successfully installed 2.8.2 in the past without this problem.

Any suggestions would be greatly appreciated.

Jay

Please Log in or Create an account to join the conversation.

More
26 Jul 2022 21:59 #248371 by andypugh
I found that my system needed a bit of help to get connected, but eventually sorted itself out.

I am using a USB Wifi dongle, as the onboard ethernet is used by a Mesa card (sometimes, it's a dedicated LinuxCNC testbed)

First, you need to find what the adapter is called.
ip link show

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eno2: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN mode DEFAULT group default qlen 1000
link/ether 7c:05:07:10:3a:44 brd ff:ff:ff:ff:ff:ff
3: wlx40a5ef05a291: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DORMANT group default qlen 1000
link/ether 40:a5:ef:05:a2:91 brd ff:ff:ff:ff:ff:ff

So, in my case the dongle is wlx40a5ef05a291 !

The commands to connect it are:
sudo systemctl enable wpa_supplicant.service
sudo wpa_supplicant -c /etc/wpa_supplicant/wpa_supplicant.conf -i wlx40a5ef05a291 &
sudo dhclient wlx40a5ef05a291

But before that will work, I needed to create a wpa_supplicant.conf file, mine looks a bit like:
network={
	ssid="Network"
	psk=0dc7ca9fe55776e6bda6b655c9ae04c3e3dba0718f08e3a9c2d2f6d53c252830
}

You can use the command "wpa_passphrase" to create the contents of wpa_supplicant.conf.
andypugh@rm-one:~/Desktop$ wpa_passphrase Network Password
network={
	ssid="Network"
	#psk="Password"
	psk=0dc7ca9fe55776e6bda6b655c9ae04c3e3dba0718f08e3a9c2d2f6d53c252830
}


 

Please Log in or Create an account to join the conversation.

More
29 Jul 2022 17:01 - 29 Jul 2022 17:02 #248626 by jay.perez1
Thanks for the reply andypugh,

The system appears to recognize the onboard NIC during the install so I can see the device name at that time: "Detecting link on enp0s25; please wait...".  It does not appear to recognize the TP-Link wireless USB network adaptor that's also plugged in.

However, the install fails at the next point: "configuring the network with DHCPv6".  I let it set at that screen overnight but it never resolves so I can't finish the install to try some of the things you suggested.

Some additional info, I've been trying to install using a USB thumbdrive. On every attempt it initially reads the drive and starts the install but quickly pops up an error message that the CD-ROM can't be read. If I move the USB drive to another port the install will continue. All of these issues happen using two different drives on two different computers.

I don't have any issues installing the previous version of LinuxCNC 2.7 on the same equipment, AND, I have previously used the same thumbdrive and ISO to install 2.8.2 on two other PCs.

My friend and I are starting to wonder if my ISP, Spectrum, may have something to do with this.

Jay
Last edit: 29 Jul 2022 17:02 by jay.perez1.

Please Log in or Create an account to join the conversation.

More
29 Jul 2022 17:35 #248632 by tommylight
There is no need for internet connection during install of the official ISO, so remove the network cable and do not connect to any wireless.
When prompted for it, choose "continue without setting the network" or similar.

Please Log in or Create an account to join the conversation.

Time to create page: 0.294 seconds
Powered by Kunena Forum