Debian 10 Buster PREEMPT-RT : trouble

More
03 Aug 2022 00:59 #248887 by currinh
I'm completely baffled and don't know what to do next. I'm installing linuxcnc on a computer pulled from my office because it has PCI slots for my existing Parallel and Mesa cards. I'm using a 5i25 Mesa card feeding a very old breakout board and Gecko drivers. The computer is an Intel i5 with I believe 4 cores. It's running 16Gb memory with one 250Gb hard disk. The monitor is an old VGA plugged into the motherboard (Intel Xeon E3-1200). There is currently an unknown DVI graphics card installed but not used. But, as below, the hardware is proven to work with 2.7.14 and 2.8.2.

I installed "2.8.2 Debian 10 Buster PREEMPT-RT" from a linuxcnc ISO download. I got no errors during installation and Debian starts right up. I kept my "/home" directory from "2.7.14 Debian 7 Wheezy". For fun I clicked on the icon to start linuxcnc. It gave me a warning that the program was old and that I could attempt an automatic conversion to 2.8.2 if I felt brave. Being brave (and using an old spare HD) I pushed the "yes" button and linuxcnc started up. Linuxcnc ran as expected (actually I was surprised) and axis motion was achieved. What we learned, 2.8.2 runs well on this hardware as configured.

I want to make some changes to the configuration, add home switches etc. So, I ran the "Mesa Configuration Wizard" on the old (2.7.14), I think it's a *.pncconf, file. The Wizard took the file with no objection. I clicked through all the screens making no changes and it generated new configuration files. When I start up linuxcnc with these new files it does not complain, but I get no axis motion on any axis. No errors but no motion. I do get a "thunk" when linuxcnc starts up. This is normal for my machine, I think from the steppers being energized. I take this as an indication that the Wizard is picking up the correct Mesa card.

I also generated a new configuration using the Mesa Wizard. I followed screen shots on my 2.7.14 install. All the fields were the same, no new questions. I get the same results as with the 2.7.14 *.pncconf file. No errors, no complaints, no motion.

Is there anyway to generate a *.pncconf file from a working linuxcnc version?  Any other ideas would be appreciated.

I'd really like to get a newer version of Debian than Wheezy. No repositories are available anymore and no updates. But I'm stuck with it till I figure out how to generate a Wizard file for 2.8.2 that works.

Thank you for any help you can provide. I'd be glad to answer any questions on the set-up if that would help.

Hugh

Please Log in or Create an account to join the conversation.

More
03 Aug 2022 07:39 #248905 by tommylight
Upload both the new and old configs here.

Please Log in or Create an account to join the conversation.

More
03 Aug 2022 10:08 #248914 by rodw
Linuxcnc 2.8 is supposed to upgrade your 2.7 config when its first opened. I have never used 2.7 so have no experience. Good Luck!

Please Log in or Create an account to join the conversation.

More
03 Aug 2022 13:24 #248930 by currinh
You mean the configs directory? That seems to be quite a few files but doable. Is there a subset to upload or include all of them?

Yes, comparing those might well shed light on the problem. I'll work to extract both.

Thank you.

Hugh

Please Log in or Create an account to join the conversation.

More
03 Aug 2022 22:37 #248978 by andypugh
Upload the new and old HAL and INI files (and please rename them in such a way as to make it unambiguous)

Please Log in or Create an account to join the conversation.

More
03 Aug 2022 23:50 #248988 by currinh
OK. Here are the *.ini and *.hal files. The version linuxcnc auto converted from an older version is icon.ini and icon.hal. The version created with the 2.8.2 Wizard is pncconf.ini and pncconf.hal. The first, "icon", is the working version and "pncconf" generated and runs but gives no axis motion.

The attached "Notes.pdf" is my attempt at applying "diff" to these files. To me the *.ini files look OK. I don't know enough to debug the *.hal files but some of the signal directions look incompatible?

This is a generic bare bones stepper system. The only thing that could be non-standard is the Mesa 5i25 board being flashed with "prob_rfx2" to match the very old PMDX-131 breakout board. However, the Wizard in prior versions is able to configure the system.

Please let me know if I can add any info. Glad to reconfigure this test HD if it might answer any questions. Thank you for the responses.

Hugh

Please Log in or Create an account to join the conversation.

More
04 Aug 2022 22:45 #249074 by andypugh
Well, it probably won't make you feel too much better if I admit that I am puzzled too.

Can you start the config from the command-line ("linuxcnc") and see if there are any hints in the terminal output?

The next thing to do would be to poke about with halshow (from the Axis "machine" menu select "show hal configuration" and make sure that the stepgen and pid for each axis are enabled.
Then look at the pid command, feedback and output.

Please Log in or Create an account to join the conversation.

More
05 Aug 2022 00:17 #249090 by currinh
Andy:

Thank you for taking a look. If you are puzzled then I'm beyond hope.

I started linuxcnc from the command line and the terminal output is attached. I redirected the output to a file, but some text still got through to the terminal window. I don't see anything obviously out of whack, but I know little of this.

I've done very little with hal, and have had minimal success making trivial mods to a working system. I'd likely just be poking in the dark, particularly when poking at a broken system. But how would I determine if stepgen and pid for each axis are enabled.

I re-loaded linuxcnc 2.8.2 from disk. Then used pncconf Wizard to configure a clean system. I got the same results, no motion. I strongly suspect many mesa 5i25 users have built working systems with this Wizard. Are there examples of success using a 5i25 flashed with "prob_rfx2"? I'm thinking it may be something inside the 2.8.2 version of the Wizard?

Thank you.

Hugh
Attachments:

Please Log in or Create an account to join the conversation.

More
05 Aug 2022 21:04 #249158 by andypugh
Well, there is something interesting here:

"icon" contains:
setp hm2_5i25.0.gpio.004.invert_output true
"pncconf" instead contains:
setp hm2_5i25.0.stepgen.00.direction.invert_output true


And also

IO Pin 001 (P3-14): IOPort
IO Pin 002 (P3-02): StepGen #0, pin Direction (Output)
IO Pin 003 (P3-15): IOPort
IO Pin 004 (P3-03): StepGen #0, pin Step (Output)
IO Pin 005 (P3-16): IOPort


So PnCConf is inverting the direction, but "icon" is inverting the step....

So I am now thinking that perhaps the step length is too short, but as it was inverted the step length was being the step space...

750nS is a very short step length.

Try bumping step length and step space both up to 5000 and see what happens. You can always adjust them down again if it works.

Please Log in or Create an account to join the conversation.

More
06 Aug 2022 00:48 #249168 by currinh
Well that made a remarkable difference. I increased "Step on Time", "Step Space" and "Dir Setup" all to 5000. That gave motions. After a little bit of testing I came down to:
Step on Time = 4000
Step Space = 2000
Dir Hold = 20000
Dir Setup = 2000
which are a little larger than minimum. A little leeway.

These are Gecko 202 stepper drivers. The Wizard suggests:
Step on Time = 500
Step Space = 4500
Dir Hold = 20000
Dir Setup = 1000
The settings in the original *.ini are likely based on these values and testing. But that has been several versions ago, they've just been transferred from prior set-ups.

I inverted the step pulses in the Wizard but that made no difference. The timing needed to be increased.

What is still baffling is the settings converted from old 2.7.14 files worked and the new 2.8.2 generated files did not. That sent us off on the wild goose chase.

I now have a working 2.8.2 version I can customize using the Wizard. Just what I needed. I still need to do checking for missed steps, etc. But I'm off and running.

Thank you so much for the help.

Hugh

Please Log in or Create an account to join the conversation.

Time to create page: 0.098 seconds
Powered by Kunena Forum