RPi4 Mesa install: No 7C81 board found

More
27 May 2023 16:33 #272270 by Stef
Dear reader,

I tried to connect to my Mesa 7C81 for the first time, by executing the following command:
sudo mesaflash --device 7C81 -–spi --addr /dev/spidev0.0 --write 7c81_5abobx3d.bit

The response that I received was “No 7C81 board found”
I think that it might have something to do with the SPI communication. Although I tried to enable this by adding a line to the config.txt file (unsuccessfully), I also found forum posts that said that SPI should not be enabled manually.

Does someone perhaps have some advice on this topic? (Or maybe is this issue not related to SPI settings?)

Please Log in or Create an account to join the conversation.

More
27 May 2023 17:29 - 27 May 2023 17:59 #272273 by cakeslob
I would start with trying to readhmid or something first
Its been a few years since I did it, Ill have to find which rpi had my notes, but from what I remember, it was something to do with

--spi
or the spidev address,
or turning on spi manually when trying to use it

edit, I found my notes. they look pretty contrived, but I think this was the successful part, as it was the last entry in my notes. its been a few years since Ive done it, so maybe its different now
i found this in the thread "mesa 7i90 in spi mode" thread and post made by sleepybishop, ,

ok i have mesaflash working with rpi4 and 7c81 card.
i have spi enabled in config, 
i rebooted system, and started up mesaflash first thing no halcmd.
this is suggested by sleepybishop in the forementioned thread
this seems like a success
pi@raspberrypi:~ $ mesaflash --device 7C81 --spi --addr /dev/spidev0.0 --readhmid
Last edit: 27 May 2023 17:59 by cakeslob.

Please Log in or Create an account to join the conversation.

More
27 May 2023 18:26 #272277 by PCW
Yes, writing firmware is not a good choice if you are unsure of connection reliability.

Please Log in or Create an account to join the conversation.

More
28 May 2023 11:47 #272333 by Stef
Thank you for your comments! 
Today I tried readhmid, but the response is still “No 7C81 board found”



This did however not surprise me, as I have not enabled SPI manually, I didn’t succeed in that yet:

Google tells me I should do this via raspi-config, but that command is not found, although I updated and upgraded my install. Perhaps that is because I am not using Raspberry Pi OS?
I am running Debian Bookworm instead (build date 2023-01-01, from this page: raspi.debian.net/tested-images/ )

 

Next, instead of using raspi-config, I tried to change the setting manually in the file boot/config.txt.
On the RPi this file does not exist, so I put the SD card in my Windows machine and opened the file there.
But the config.txt file told me not to modify it, but go to another file instead.



 

I tried to create a new textfile and save it as /etc/default/raspi-extra-cmdline, but this is not possible. I received the warning “The document is read-only, do you want to save it as another file?”.



So unfortunately I haven’t been able to enable SPI. Perhaps am I doing something wrong?
Attachments:

Please Log in or Create an account to join the conversation.

More
28 May 2023 15:47 #272344 by cakeslob
just do it with the GUI one in the start menu, its a check box thing.

Then reboot, and do the mesaflash before anything else

Please Log in or Create an account to join the conversation.

More
28 May 2023 18:27 #272357 by Stef
Thanks for your advice, but where in the start menu could I find the setting? 
When I Google it it looks very easy, but all the explanations seem to be aimed towards Raspberry Pi OS. In my installation I for example don't have the "Preferences" button, my start menu looks like this:

Attachments:

Please Log in or Create an account to join the conversation.

More
29 May 2023 03:05 #272390 by cakeslob
ohhh you are using debian instead of raspi-os. that would explain why things arent working. I do not think you can change things with a config file like with rpi-os or use raspi-config, as debian is not using the dbts. I also dont think the hm2_rpspi driver works with debian bookworm anyways

Please Log in or Create an account to join the conversation.

More
29 May 2023 03:10 #272391 by rodw
Debian should work OK o na Pi. It does for me. 
The problem you are having I think is that you need to edit files outside your home directory and you don't have edit rights. You need to be logged in as root to do that.

try
sudo apt install geany
sudo geany

Then edit the file you want to.

Please Log in or Create an account to join the conversation.

More
29 May 2023 05:48 #272401 by cakeslob
does the spidev driver work also?

Please Log in or Create an account to join the conversation.

More
29 May 2023 13:19 #272428 by PCW

does the spidev driver work also?
 

It works as I recall but was unusably slow

There is no reason I can think of that the hm2_rpspi driver would not work on Debian
in fact is should be quite OS independent since it does direct hardware access.

7C81s are shipped with 5ABOBx3 firmware so LinuxCNC may just work without
needing to run Mesaflash ( which does require that the kernel SPI driver be enabled )

Rodw is spot on about getting a working editor and editing the appropriate startup file
as root on the RPI.
The following user(s) said Thank You: rodw

Please Log in or Create an account to join the conversation.

Time to create page: 0.462 seconds
Powered by Kunena Forum