Failed to install linuxcnc2.9.2

More
10 Feb 2024 14:51 #292997 by machinedude
i wish i could say i was having better luck with this but i am not. i think i am having problems with my interfaces  so when i mount boot media my wired connection is getting missed while doing the install. i have a internet connection  and have the Debian 12,4 working but am not seeing the eth0s connection anywhere other than the( ip a) command in terminal. When i try to go further and edit this the loop back is the only one that shows up to edit?
the network configuration is the hang up point on the installation for me.

Please Log in or Create an account to join the conversation.

More
10 Feb 2024 15:55 #292999 by tommylight
There is no eth0 on new versions of Linux, the naming is very strange now like eno1 or enp0s25, etc.
Having installed Debian 12.n on several PC from quite old to new, never had any issues with networking, i wonder what is causing all these issues for you.
Try Linux Mint Debian Edition 6 from here:
www.linuxmint.com/edition.php?id=308
After installing it, in a terminal
sudo apt update
sudo apt install linuxcnc-uspace
Nothing more or less.

Please Log in or Create an account to join the conversation.

More
10 Feb 2024 16:53 #293009 by machinedude
downloading now so i will try again and post results as soon as i can.

Please Log in or Create an account to join the conversation.

More
10 Feb 2024 18:29 #293021 by machinedude
well it did something! do i have to do anything else while i am in the terminal? it looks like it is finished.

Please Log in or Create an account to join the conversation.

More
10 Feb 2024 18:35 #293022 by machinedude
happy days :) that worked and i now have it on the computer. :)
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

More
10 Feb 2024 19:46 #293031 by tommylight
Nice, thank you for reporting back.
The following user(s) said Thank You: machinedude

Please Log in or Create an account to join the conversation.

Time to create page: 0.369 seconds
Powered by Kunena Forum