Linux install problem with 2.9.2 iso

More
27 Mar 2024 11:29 #296882 by tommylight
Before this gets out of hands, Rod, boot sector is on the drives and he used several, so the only common denominator remains the PC/MB, and that is .... well i did not want to say this before but i do have an Acer Switch 5 that did/does the same thing, it was working 24/7 when after reboot stoped working with missing disk error, tried 2 other NVME disks, same error, can be installed without errors on all, but it just wont boot.
Having a sample of 1 is not a reference, so i refrained from mentioning it.
I resorted to using it with a USB-NVME case externally, it is still on 24/7.
-
Does the PC have more than one NVME slot? Try the other.
Does it have SATA ports? If possible try a SATA SSD or HDD.
If you have anything with Linux already installed, just plug it in and try to boot.
The following user(s) said Thank You: dokwine

Please Log in or Create an account to join the conversation.

More
28 Mar 2024 18:40 #297019 by dokwine
So. Waiting for AMZ to show up with a new drive. Decided to try reset CMOS. Checked config and booted. No change. Re-installed and booted. No change.

There was one last SATA port I could reach but hadn't tried. Booted; No change. Re-installed and booted. No change. Time to move on to other things. While rummaging through my cable pile for some line cord a SATA cable turned up. Why not. Plugged it in, Booted, Debian loaded, all is fine. Re-booted multiple times - all is well.

I was ready to accept that I would be going down the USB-NVME route as tommylight suggested (not pretty, but fine). But: bad cable was the culprit. In fairness (to me) this cable had been re-seated on both ends while I was debugging this (multiple times), nothing had moved since the last boot AND the old cable had worked well enough to install a fresh copy of BW/LCNC - multiple times! The image was fine. I started re-storing my config's and everything on the disk (installed via the "bad" cable) was fine.

Of course then I came to my senses and re-installed from the iso with the new cable anyway. (all in UEFI mode, working great Rod).

So thanks for the support from everyone. I wish I could say I understood how what is essentially a serial cable worked well enough for an install, but not well enough to boot. I'm guessing perhaps error correction/re-try was available for read/write on installation but not available for bios on booting. Perhaps you have insights. In anycase I'm back up - THANK YOU!

Ron

 
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

More
28 Mar 2024 23:06 #297048 by tommylight
I've had multiple time SATA cables causing all kinds of issues, mostly really slow read/writes to HDD/SSD, but i never had one fail completely, so this is new.
Thank you for reporting back.

Please Log in or Create an account to join the conversation.

Time to create page: 0.066 seconds
Powered by Kunena Forum