WHB04B-6 - Change display units and step sizes

More
12 Apr 2024 19:20 #298108 by 109jb
Hi All,

I have searched the forum and cannot find a solution for my problem.  I have a milling machine step up on LinuxCNC with a wireless WHB04B-6 MPG pendant. All is working.

My problem is that I usually work in inch units and the pendant is always in metric units. If I switch the LinuxCNC to show inches, it does on the LinuxCNC GUI, but the pendant still shows the metric units. Also, when jogging by step using the pendant, the jog distance is metric. For example, setting the jog step to say 0.1, it moves 0.0039 inches. I realize this is 0.1mm, so the pendant is doing everything in the base units of mm. 

I think I have a not so great workaround but haven't tried it yet. My mill setup right now is  called "Mill" of all things.  I could create another machine definition called "Mill Inches" and when setting it up, set everything so that the base units are in inches.  When LinuxCNC thinks it is moving the machine 1mm, the machine actually moves 1 inch. I see 2 problems with this
  1. The first problem here is that you would have to run in G21 to have inches, and G20 would just be flat out wrong. Any code I would have to remember this snafu and I figure eventually I would forget.
  2. The display resolution is different between inches and mm by a factor of 10. Not that my machine is actually capable of 1/10,000 inch accuracy.

Is there a way to change this so it will work in inches or in mm and can switch within LinuxCNC? Or an I forced to use my workaround?

BTW, just so you know, I am not a programmer, or well versed on the inner workings of LinuxCNC. I struggle but usually am able to suffer through. I just may need more basic instruction than others.  

Thanks,

John Brannen

Please Log in or Create an account to join the conversation.

More
13 Apr 2024 17:52 - 13 Apr 2024 17:53 #298185 by 109jb
For anyone in the same situation, I figured this out today and solved my problem.

The WHB04B pendant apparently just always uses the units in config.ini that define the machine. I had originally defined my machine in config.ini in millimeters, and so the pendant always used mm no matter what I had selected for display in the Axis gui. All I had to do was duplicate the machine and edit the config.ini to be in inch units. A little calculator work and everything is good. I have 2 machines defined for LinuxCNC for the same physical machine, one named "Mill_inch" and one named "Mill_mm". I just have to choose the appropriate one for the units I am working in at the time. Easier than I thought it would be.
Last edit: 13 Apr 2024 17:53 by 109jb.

Please Log in or Create an account to join the conversation.

Time to create page: 0.168 seconds
Powered by Kunena Forum