PC won't boot with 5i25 in 1 of 2 avail. PCI slots

More
10 Apr 2014 16:03 #45783 by akb1212
As topic says I'm unable to get my computer to boot when I install my 5i25 in one of the 2 available PCI slots in my motherboard.

The hardware is as follows: ASRock B75-Pro3 Socket 1155 MB, 4x2 gigs of ram, Intel i5-3470 CPU.

All jumpers are in default positions on the 5i25. For the time being I haven't connected any of the daughter cards (I have one 7i77 and one 7i74 I plan on using with it).

It's now consistent behaving like this: If I attach the 5i25 to the PCI slot furthest away from the CPU the only thing that happens if I try to turn the computer on is that the fans will start (at a lowsih speed), and nothing else. No boot sequence and no more action. No beeps from the speaker. When I turn off power there is a brief blink of a red LED on the 5i25 card.
If I move the card to the other available PCI slot it will boot, then reboot, then reboot again (or some variations of number of reboots). This time the screen comes up as normal, and when it eventually finishes rebooting it starts up as normal.
If I keep the card in that port it will keep working (and I hope it will continue to do so...) as normal with no problems.

BUT, if I put the 5i25 back in the first PCI slot (which is where I wanted it in the first place, from a practical point of view as far as internal cabling and such) it will no longer boot. Not until I remove the card or put it back in the other slot. When I install it back in the working slot (after having been in the other slot) it will do the rebooting dance once more, with the red LED blinking at times (not sure at what time in the sequence). Then at the next start-up it will once again start up as normal.

My question is: Do I need to worry about this? The card is at least one year old, and I expect it to be rev A.

I would like to keep this motherboard in the computer as I have 2 of them, the other being installed in the same kind of cabinet with a Galil controller and I would like to do comparisons between LinuxCNC and Galil. So I would prefer not to have to replace that MB. I'd like to keep everything as equal as possible when doing the comparison. I'm making in effect 2 control systems with the possibility to swap them out at will. I will also be able to swap in the original Philips 432/10 controller. All to compare. I will also work out how to use LinuxCNC to monitor the movement of the other systems to assess their performance and compare hard data from the different systems.

BTW, the system has decent (???) latency times (13000 and 16000 I think it was, with no core isolation, running over night) so also from this perspective I'd like to keep it.

Please Log in or Create an account to join the conversation.

More
10 Apr 2014 18:52 #45788 by PCW
As a first step, I would try cleaning the PCI slots
(card stock dipped in 99% Isopropyl alcohol works well)
and 5I25 contact fingers

A 5I25 should always blink both red LEDs at powerup

When the system does boot , is the 5i25 found?

Please Log in or Create an account to join the conversation.

More
27 Apr 2014 20:18 #46371 by akb1212
I have now tested this card in 2 computer with almost identical MB. Only minor differences in BIOS versions. They both show the same behavior:
It will boot when I install the 5i25 in the PCI slot closest to the CPU. Then I'm able to find the card using the BIOS system browser. It shows up as data acuisation card, which I assume to be correct. The computer starts normally and will load the OS as expected.
If I install it on the PCI slot furthest away from the CPU I get no boot, only CPU fan spinning. USB connected mouse doesn't light up the red LED for tracking. The only thing working is to hold inn the power button for >5 seconds, which makes the computer turn fully off.

This is 100% reproducible on both of these MB, even after switching several times back and forth...

And I have installed other PCI cards in those spots. Both a new network card and a USB expansion card works as expected in those ports. The same goes for a 96 I/O card I use on the other computer with Windows.

The two red LED's on the 5i25 flashes when powered on as you mention.

When running PnCConf Wizard in Linux I also have some problems. I'm not sure how I'm supposed to test the communication with the 5i25 card. Is there an easy way to test this? The documentation on this isn't quite easy to follow, or are totally outdated..... I also read that Mesa software require ver 2.6 of LinuxCNC, which is not straight forward to install for someone unfamiliar to Linux.....

Can you please point me to a straight forward way for me to test if my Mesa hardware is working? I have a 7i77 and a 7i74 hooked up to it, and a 7i84 connected to the 7i77. I also have a 7i73 not hooked up yet.

I also find it difficult to use the wizard because the 7i74 isn't available in the configuration. Neither is the 7i84 I have.....

To top that up the field power indicator on the 7i77 doesn't light up even if I have 12V hooked up to VIN, and set the jumper correctly.

And I'm unable to increase the number of PWM generators from 0. The up arrow is grayed out in that window, so I'm not allowed to specify more than 0 PWM generators. But I can find them on the other pages and configure them. But I can't find them if I start the test window.

And I do find the SSerial configuration quite confusing with regards to channel numbering and such. And no guide to explain how it works. Is there one?

I realize this makes me look like I'm a total newbie at this. The truth is that I'm quite familiar with computers and CNC machines, only not much experience with Linux, although I started looking at EMC back in 1998.
But I have to say this whole thing with Linux and no concise and straight forward documentation isn't winning me over here. Sorry for being so pessimistic, but I didn't expect to meet this many problems to start with.....

Please Log in or Create an account to join the conversation.

More
27 Apr 2014 21:42 #46374 by PCW
Do the red lights blink more than once at startup? If so you, have a 3.3V power issue (red indicates a 3.3V low voltage state
so the red lights blinking is expected to occur only once at power up)

On possible issue with working in only one slot is that the 5I25 indicates that it requires 15W. if the BIOS does not allow this, it will not start (Thats about the only reason I can think of for differences between the slots since all PCI bus signals are the same between slots except for REQ/GNT and IDSEL and the INT lines)

You might try updating the BIOS on you MB in case this is a BIOS issue

Before you connect daughter cards I would also check that you dont have a power conflict (make sure that the7I77 and 7I74 5V cable power options match the 5I25 5V cable power options )

Note that a 7I74 is just a dumb RS-422 interface, it is not detectable or a selectable setup option only devices attached to the 7I74
are detectable.

On the 7I77, the field power LED is illuminated when field power is applied. With the standard jumpering (W1 left)
you apply field power (+ to VFIELD) and leave VIN unconnected.

Note that LinuxCNC 2.6 is not required for anything you are doing, but fetching the latest pnconf will probably help

probably the easiest way to test the cards without a configuration file is to use halcmd:
$>halrun
halcmd: loadrt hostmot2
halcmd: loadrt hm2_pci 
halcmd: show pin 

This should show the 5i25's available hal pins and the 7I77 / 7I84 / 7I73 available hal pins
if those cards are attached and powered correctly.

If you are using a 7I77+7I74 FPGA configuration, there are 2 sserial ports
(one for the 7I77 and one for the 7I74)

The 7I77 sserial channels (on port 0) are:
0 digital I/O
1 analog I/O
2 7I77 expansion RS-422 connector

The 7I74 sserial channels (in port 1) are 0 through 7

DId you look at the hostmot2 manual?
man hostmot2

Please Log in or Create an account to join the conversation.

More
28 Apr 2014 00:42 #46380 by PCW
BTW here is a simple 7I77 config that should at least get the
serial interfaces working for test purposes:

freeby.mesanet.com/7i77.zip

Please Log in or Create an account to join the conversation.

More
28 Apr 2014 03:42 #46386 by akb1212
Thanks for the fast support! That was a definite plus!

Ok, first I wasn't able to make the halrun work. It gave errors there was a low voltage on my 7i84. So I disconnected that for now.

That made it possible to run, and it showed me the IO pins. But there were no PWM pins there. Only general pins and encoder pins.

When I try to run LinuxCNC now it comes up with an error saying: parameter or pin 'hm2_5i25.0.7i77.0.1.analogout0-scalemax' not found

There is a long list of what happens in the window, but I have no idea on how to copy the content of that window. No ways I know of (Ctrl-C) or right clicking the mouse gives me an option to copy the content in the window.... there is probably an instruction on how to do that somewhere, but I don't know where to look for that.
Kind of strange to instruct me to provide the information and no way to enable me to copy it so I can include it in the message.....

And I haven't learned how to use the file you used yet. Linux is quite challenging to get the grips of....

Could the reason I'm unable to configure the PWM generator in PnCConf that it's not working somehow. From what I got when I ran 'show pin' they aren't there..... and Linux CNC seems to refuse to start because it can't find any of them.....

I need to look in to upgrading the firmware of my cards as well.... I hope that is straight forward...

The red LED's blink only once.

Please Log in or Create an account to join the conversation.

More
28 Apr 2014 04:11 - 28 Apr 2014 04:13 #46389 by PCW
The 7I84 error probably means the you don't have field power to
both of the 7I84s field power inputs

There are no PWM pins. All analog output pins will have names like:

hm2_5i25.0.7i77.0.1.analogout0

But it appears that the 5I25 is not communicating with the 7I77 for some reason
(the hm2_5i25.0.7i77.0.1.analogout0-scalemax' not found error indicates a problem)

Possible reasons:

1. 5I25 and 7I77 power jumpers not set correctly

For 7I77 5V power from DB25 cable:
7I77 W5 LEFT
5I25 W2 UP

For 7I77 power from TB1
7I77 W5 RIGHT
5I25 W2 DOWN
(5V must be supplied to the 7I77s TB1 in this case)

2. 7I77 on wrong connector (should be P3 for 7i77_7I74 configuration)

3. Wrong 5I25 firmware

For power issues, make sure that the above jumpering is correct and
both CR1 and CR3 (5V and field power) LEDs are on
(these are yellow LEDS on the top edge of the 7I77)

its generally better to run linuxcnc from a terminal when debugging
Then the normal copy/paste characters or menu work
Last edit: 28 Apr 2014 04:13 by PCW.

Please Log in or Create an account to join the conversation.

More
28 Apr 2014 23:48 #46438 by andypugh

But it appears that the 5I25 is not communicating with the 7I77 for some reason
(the hm2_5i25.0.7i77.0.1.analogout0-scalemax' not found error indicates a problem)


Which version of LinuxCNC? I wonder if the pin names changed? (I think I spelled the word "analogue" correctly in some versions of the driver :-/

One option that might make keeping track of sserial devices easier is to use the option to reference them by serial number rather than connection position.

Please Log in or Create an account to join the conversation.

More
29 Apr 2014 03:03 #46443 by BigJohnT
To copy and paste in some windows in Linux the middle mouse button is the one to use. Select all the content with the left mouse button then click the middle on the text then click it again in an open text file.

JT

Please Log in or Create an account to join the conversation.

More
29 Apr 2014 16:28 #46464 by akb1212
Ok, I was able to make LinuxCNC start up now using the config provided by PCW, thanks!

The only test I was able to do (because of hardware available) was to read the encoders. I have one loose scale that I plugged in to all axes one after the other. And they all seemed to work.

That means I have communication with the 7i77.....

I use the latest version, 2.5.4.

It was the 7i77 that was plugged in the wrong (but to me correct) connector. My layout is with the 7i77 inside the same cabinet, so initially I found it logical to connect that to the internal connector with a short cable. Is it possible to change these around? If not I will have a bigger mess in my cabling to deal with.....

I have some issues with field power though. Initially I connected a separate (internal 12V from PC) power to the output logic to power it up because I'm not hooking it up in my mill to power the +24V lines yet. With that I wasn't able to make the output logic work (no yellow LED light up on the side of the connector). But it worked when I moved the +12V to the field input... I will look in to that.

On copying text in Linux.... I did try all buttons on the mouse, including the middle. No reaction (and no drop down menu) on either middle or right hand mouse button. Only left button reacted, but it's not possible to copy anything with that alone....
One thing though.... is it possible to make Ctrl-C and Ctrl-V work? I find it incredibly annoying to have to use the mouse to do this when I'm used to these shortcuts.

I will try to get my head around the *.hal and *.ini file way of thinking. I find the way Linux is thinking about (too) many t things to be somewhat different. So many small details I'm used to know (coming from a windows world) I find I have to re-learn now...... sigh.... :S

Please Log in or Create an account to join the conversation.

Moderators: cmorley
Time to create page: 0.522 seconds
Powered by Kunena Forum