Fusion 360 Lathe Post #2

19 Jan 2022 23:52 #232492 by currinh
I'm sorry but I'm baffled. I have my lathe converted and am trying to make my first part using Fusion 360. The threading canned cycle seems to be misbehaving. I'm sure it's simple and my fault, but I have no idea where to start my search for sanity.

LinuxCNC throws an error as soon as I load this lathe part. I'm using the standard LinuxCNC Post for turning.

  LinuxCNC Lathe post processor configuration.
  $Revision: 43470 147f5cf60e9217cf9c3365dc511a0f631d89bb16 $
  $Date: 2021-10-13 20:53:32 $

The error comes from the threading canned cycle. The command Fusion generates is:

G76 P0.0689 Z-0.745 I0.9526 J-0.0148 K-0.074 R1. Q0. H0. E0.037 L0
    (P = pitch thread/inch)
    (Z = final position of threads)
    (I = thread peak from drive line - neg for external)
    (J = initial cut depth - positive)
    (K = full thread depth - positive)
    (R = depth degression - 1.0 constant : 2.0 constant area)
    (Q = compound slike value - typical 29.5 deg)
    (H = number of spring passes)

LinuxCNC rightfully complains about the negative J value. I don't see where in my model that could come out negative. It is not a direct input.

The Post Processor includes the following to generate the G76 call:

        "P" + spatialFormat.format(cycle.pitch),
        "I" + xFormat.format(threadClearance),
        "J" + xFormat.format(firstDepthOfCut),
        "K" + xFormat.format(threadHeight),
        "R" + spatialFormat.format(threadCuttingMode),
        "Q" + spatialFormat.format(cuttingAngle),
        "H" + spatialFormat.format(repeatPass),
        "E" + spatialFormat.format(chamferWidth),

Thus the J value is in firstDepthOfCut. I tracked this down and find it comes from the following code a little before the G76 generation above.

      // thread height and depth of cut
      var threadHeight = getParameter("operation:threadDepth");
      var firstDepthOfCut = threadHeight / getParameter("operation:numberOfStepdowns");

I believe getPparameter indicates these are directly from Fusion 360. The thread depth and "number of step downs" are familiar from the entered values within the thread operation in Fusion.

Has anyone seen similar problems? Has anyone used this October 2021 Post Processor? Let me know what additional information might be useful. As I said I have no idea how to start tracking this down. Any ideas would be greatly appreciated.

Thank you for any help.



Please Log in or Create an account to join the conversation.

21 Jan 2022 18:27 #232668 by currinh
Replied by currinh on topic Fusion 360 Lathe Post #2
Well, I can reproduce this problem. I've had Windoze brick on me twice while tracking this down. I hate Windoze. I lost or deleted the model that was causing problems. I've tried all permutations I believe I'd made in that and don't see the problem.

Best case: I declare the problem solved and will move on. Hopefully I never see that again.



Please Log in or Create an account to join the conversation.

Moderators: Skullworks
Time to create page: 0.094 seconds
Powered by Kunena Forum