Fusions CAM drives me crazy - Axis out of bounds

More
10 Jun 2024 20:54 #302778 by Emanresu
Hello together,

after running through multible problems with Fusion360s CAM, now i have one, where i dont see any light.
For some reason im runing out of my soft limits.
As you can see in the attached image, thats not the case. Also Origin is right.

Do you have any ideas?

File Attachment:

File Name: G61_0.01.ngc
File Size:1,235 KB


Attachments:

Please Log in or Create an account to join the conversation.

More
10 Jun 2024 21:51 #302781 by MaHa
I was able to run the file in my simulation without problem. Line N50 G43 Z25. H1 , if distance Z25 to G53 Z0 is lower than toollength, it will give an error.
 
The following user(s) said Thank You: Emanresu

Please Log in or Create an account to join the conversation.

More
10 Jun 2024 22:51 #302786 by jimmyrig
Ran into this when programming a lathe. Mill may be different.

Rotate your screen so you can see z axis as well.
My guess is it moves z to a "safe height" before traveling via that g53. Just delete that line and see if the output on the screen looks reasonable. If it does when you go to post in fusion set the safe height parameter to something more reasonable.


If that's the issue you can remove it from the post processor entirely
The following user(s) said Thank You: Emanresu

Please Log in or Create an account to join the conversation.

More
11 Jun 2024 04:14 #302792 by Emanresu
Oh, everything is fine with Z.
I run out in X and Y. (Red on the picture)
Y83.8 and X152.4

The fun part is, when i "touch" G54 to another position, it sets the origin perfectly fine, as every time.
But Y83.8 and X152.4 just stays red, and i get an error, if i try to run the gode.

Please Log in or Create an account to join the conversation.

More
11 Jun 2024 15:02 #302827 by jimmyrig
Huh weird... It looks like all your x and y lines are in the bounds of the machine..... Are you sure their isn't a random line somewhere?

If not it's probably not fusion.

I'd check your ini file on your x and y axis max and min limits as well as the corresponding joints.

Feel free to post the file

Please Log in or Create an account to join the conversation.

More
11 Jun 2024 15:31 #302831 by Emanresu
Yeah hehe, its weird.

I can upload my ini when im home, but im 100% sure everything is fine.
Just loaded an huge car doorpanel, did long ago and it worked just fine.

It gets even cooler.
If i set my machine to G54, the piece goes into the corner and clearly out of my workspace. BUT.... All numbers are fine.

I try to clear every G out of that Gcode and strip it naked. Lets see, what might happen then.

Please Log in or Create an account to join the conversation.

More
11 Jun 2024 19:29 #302846 by Emanresu
Ok, found an super easy solution!

Just use FreeCAD and everything works fine. Just like "what you click is what you get".

But if anyone whipes the dust from this topic some day, please leave an anssumption.
Im still curious, how an G-code is able to trigger an "out of bounds" inside the workspace.
Fusion coders must be one of a kind.

Anyway, thx to everyone who tryed to help! Still a super nice community!
 

Please Log in or Create an account to join the conversation.

Moderators: Skullworks
Time to create page: 0.107 seconds
Powered by Kunena Forum