File Open Dialog - No Network Drives

More
26 Jan 2016 14:36 #69118 by HDVideo
Is //windows_share/ in the mount command the full path? for example: D:data/cad_cam/toolpaths/
If for example, the "data" folder and all sub-folders are shared on the Windows system, can I eliminate the sub-folders in the mount command?
Also, are the path and filenames case sensitive?

Thanks for all the help with this issue!

Please Log in or Create an account to join the conversation.

More
26 Jan 2016 15:03 #69123 by ArcEye

Is //windows_share/ in the mount command the full path? for example: D:data/cad_cam/toolpaths/
If for example, the "data" folder and all sub-folders are shared on the Windows system, can I eliminate the sub-folders in the mount command?


The path is //server-name/window_share_name.
I don't know what your server name comes up as, but it will be whatever the file manager can access it as
D: is meaningless outside of windoze, both as a designation and because it is local to another computer

If you have access to the root directory and all sub-directories are set to allow sharing, yes you should be able to just specify the root directory and then navigate to others as required, just as you would on a local file system.

Also, are the path and filenames case sensitive?


Always in Linux

I don't know a huge amount about file sharing with windoze on a practical level, because I negate the need for it, by not using windoze, or just transfer files on a USB stick if I cannot avoid it :P

Others may well have practical tips for the easiest methods of connection etc.

regards
The following user(s) said Thank You: HDVideo

Please Log in or Create an account to join the conversation.

More
26 Jan 2016 16:40 - 26 Jan 2016 16:42 #69125 by Todd Zuercher

Is //windows_share/ in the mount command the full path? for example: D:data/cad_cam/toolpaths/
If for example, the "data" folder and all sub-folders are shared on the Windows system, can I eliminate the sub-folders in the mount command?
Also, are the path and filenames case sensitive?

Thanks for all the help with this issue!


Depending on what your windows computers name is. If it is "windows-pc" the path would be
//windows-pc/data/cad_cam/toolpaths/
Last edit: 26 Jan 2016 16:42 by Todd Zuercher.

Please Log in or Create an account to join the conversation.

More
26 Jan 2016 19:06 #69128 by HDVideo
I think I'm almost there, but still getting Access Denied errors on the mount command. It's asking for a password when the command is entered and I've tried my LinuxCNC system password as well at my Windows password with the same results. Attached is a screen grab if anyone has an idea what I'm doing wrong. The folder winbox has been created in the nc_files folder.

Please Log in or Create an account to join the conversation.

More
26 Jan 2016 21:17 - 26 Jan 2016 21:23 #69134 by Todd Zuercher
The password prompt after issuing a sudo command will be your linux password.
You can add at the end of the comand -o username=your_windows_user_name, password=your_password
sudo mount.cifs  //video-pc/cad_cam/Aspire/Toolpaths/  home/ed/linuxcnc/nc_files/winbox/ -o username=your_windows_user_name,password=your_windows_password
Last edit: 26 Jan 2016 21:23 by Todd Zuercher.

Please Log in or Create an account to join the conversation.

More
26 Jan 2016 21:59 #69136 by HDVideo

The password prompt after issuing a sudo command will be your linux password.
You can add at the end of the comand -o username=your_windows_user_name, password=your_password
sudo mount.cifs  //video-pc/cad_cam/Aspire/Toolpaths/  home/ed/linuxcnc/nc_files/winbox/ -o username=your_windows_user_name,password=your_windows_password


I did try that earlier and received a different error that I forget at the moment. I think it was a syntax error of some sort, so I'll give it another try. The Windows shares were all made public so no password should be needed, I would think, but not really sure.

Please Log in or Create an account to join the conversation.

More
29 Jan 2016 19:00 #69252 by HDVideo
Woo-Hoo - Finally got it to work!

I was getting "Failed to open Windows Network - Failed to retrieve share list from server" errors for a couple of days, but once that was fixed, the mount.cifs command worked. The problem I was having before the "Failed to open..." error popped up was I needed to put // in front of home in the command line. I also needed the username/password to make it work.

Now to see if I can modify the fstab file to make the mount permanent.

Thanks a bunch for helping us Linux challenged users! I really appreciate it.

Ed

Please Log in or Create an account to join the conversation.

More
07 Jul 2016 07:09 - 07 Jul 2016 07:11 #77129 by eFalegname
Hi Ed, II did not succeed to do the mount with cifs. :sick:
Found the directory where linuxmint mounts my network drive then I linked it to my nc_file directory.
ln -s -f '/run/user/1000/gvfs/smb-share:server=192.168.1.1,share=volume(sda1)/BM' '/home/ef/linuxcnc/nc_files'
Now I have to mount the network drive at startup
Last edit: 07 Jul 2016 07:11 by eFalegname.

Please Log in or Create an account to join the conversation.

More
07 Jul 2016 10:59 - 07 Jul 2016 21:11 #77136 by eFalegname
Ok, I have some updates maping my USB router network drive to share:
My linuxcnc runs on linuxmint mate 17.3 with cifs-utils installed by default. Anyway you can install cifs on your system:
sudo apt-get install cifs-utils
1. In order to mount the shared drive I created a directory named BM inside the nc_files:
sudo mkdir /home/ef/linuxcnc/nc_files/BM
2.Opened the fstab file and added a row to link the USB router drive (remote "BM" directory) inside my nc_files directory with the "BM" local. This mounts the network drive at linux startup:
sudo pluma /etc/fstab
//192.168.1.1/volume(sda1)/BM	/home/ef/linuxcnc/nc_files/BM	cifs guest,rw,uid=1000,gid=1000,nounix,iocharset=utf8,file_mode=0777,dir_mode=0777  0	0
3.Saved and reloaded fstab file
sudo mount -a
options meaning:
cifs - partition type
guest - no password protect connection required
rw - mount read/write rights
uid and gid - user id. You can retrieve it with the command:
cat /etc/passwd | grep your-linux-username
nounix - disable cifs unix extensions so that no UNIX ACL, path and lock will be used.
iocharset - non english languages character support
mode - permissions
0 - back up drive
0 - fsck command (at boot time)

Fstab Ubuntu-help
Last edit: 07 Jul 2016 21:11 by eFalegname.

Please Log in or Create an account to join the conversation.

Moderators: newbynobiHansU
Time to create page: 0.110 seconds
Powered by Kunena Forum