Touchscreen Keyboard

More
07 Feb 2016 21:41 #69750 by 10K
Touchscreen Keyboard was created by 10K
I have a touchscreen interface that I'm using with gmoccapy. The documentation says that it works with two keyboard programs, matchbox-keyboard and onboard. Neither was installed on my Debian 8 installation, so I loaded matchbox-keyboard. I can now get the on screen keyboard from the terminal window, but not in gmoccapy.

In gmoccapy, when I go into the MIDI window and touch the keyboard icon, it blanks out the bottom of the screen, but no keyboard. How can I get it to work?

Please Log in or Create an account to join the conversation.

More
09 Feb 2016 16:16 #69857 by newbynobi
Replied by newbynobi on topic Touchscreen Keyboard
I have not made any tests on that on debian 8.
May be someone can give me a hand, as I am running out of time at the moment.

I will have to check on that. please be patient.

Norbert

Please Log in or Create an account to join the conversation.

More
17 Feb 2016 15:12 #70286 by auto-mation-assist
I'm also running Debian, but not sure of the version right now, I installed matchbox-keyboard about a week ago and it showed up in in Gmoccapy 5 axis just fine. I let my computer run for several days and then re-booted. After this the matchbox-keyboard did not show up anymore in Gmoccapy 5 axis. LinuxCNC was up to date on V2.7 at that time. Today I updated V2.7 since there was one change and also grabbed Gmoccapy 5 axis again. Then did a build and restarted Linuxcnc as usual and the matchbox-keyboard showed up again in Gmoccappy 5 axis. Sometime after this I rebooted the computer and restarted Gmoccapy 5 axis. The matchbox-keyboard was gone again. No other changes were made. I'm confused on why this is happening.

Please Log in or Create an account to join the conversation.

More
17 Feb 2016 15:18 - 17 Feb 2016 15:21 #70287 by auto-mation-assist
Network problem created duplicate post. Content was same as above post.
Last edit: 17 Feb 2016 15:21 by auto-mation-assist.

Please Log in or Create an account to join the conversation.

More
25 Feb 2016 21:10 #70637 by 10K
Replied by 10K on topic Touchscreen Keyboard
I replaced Debian 8 with Debian 7 (long story, see my other posts), and the touchscreen keyboard is now working.

The letters on matchbox-keyboard are tiny and hard to see and I'd like to try Onboard. It's packaged for Ubuntu, and have not had any luck installing it on Debian 7. I've read some older posts on this topic, but installation of the various components give errors. Has anyone had any luck installing Onboard on Debian?

Please Log in or Create an account to join the conversation.

More
25 Feb 2016 21:32 #70639 by newbynobi
Replied by newbynobi on topic Touchscreen Keyboard
Why are the matchbox-keyboard buttons so tiny?
Do you have a screenshot?

I also tried to get onboard to work on debian, but also without success.

Norbert

Please Log in or Create an account to join the conversation.

More
26 Feb 2016 14:27 #70672 by 10K
Replied by 10K on topic Touchscreen Keyboard
Here's a screenshot showing the small letters.

Please Log in or Create an account to join the conversation.

More
13 Mar 2016 13:39 #71561 by newbynobi
Replied by newbynobi on topic Touchscreen Keyboard
@10k

sorry for the delay,
I made some tests and the best I could find is to modify the layout.
I made one for a German keyboard.

To test please make a dir .matchbox in your home directory
Place the attached file in there and rename it to keyboard.xml

start your config and check if that would be better.

Norbert

Attachments:
The following user(s) said Thank You: 10K

Please Log in or Create an account to join the conversation.

More
13 Mar 2016 15:25 #71567 by 10K
Replied by 10K on topic Touchscreen Keyboard
Thanks for taking a look at this!

Still very small. Font size is about the same. Here's a screen capture:

Please Log in or Create an account to join the conversation.

More
14 Mar 2016 07:48 #71608 by newbynobi
Replied by newbynobi on topic Touchscreen Keyboard
Could you please try to change the global font settings of your window manager?

Mine is set to SANS 10, if I set it to SANS 12, the fonts of the keyboard do get larger.

Norbert

Please Log in or Create an account to join the conversation.

Moderators: newbynobiHansU
Time to create page: 0.128 seconds
Powered by Kunena Forum