Some controls not functional after update

More
07 Apr 2016 19:49 #72928 by mariusl
I just updated my production system to the latest automatic update and found that there are some issues that are new.

When using a touch screen on Gmoccapy and you go to load a new gcode file, the green "right mark" button to load the selected file does not come alive. You have to move the cursor or selection to another file with the left and right arrows on the screen before the green select button is active. Very frustrating new feature Norbert :whistle:

Regards
Marius


www.bluearccnc.com

Please Log in or Create an account to join the conversation.

More
08 Apr 2016 21:09 #72978 by newbynobi
Hay Marius,

You should know me by now:-)
It is allready fixed:-)
I have pushed the bugfix a week ago,but i have no influence on the pubification of new packages.

If you do replace iconview.py with the file from master, all should be OK

Norbert

Please Log in or Create an account to join the conversation.

More
09 Apr 2016 06:13 #72988 by mariusl
Thanks Norbert. You are a champion.

Regards
Marius


www.bluearccnc.com

Please Log in or Create an account to join the conversation.

More
24 Jun 2016 14:35 #76567 by LAIR82
Hello Norbert,

For some reason this isn't working, I tried to move the new iconview.py file to the directory to replace it, and I get it moveed properly, but it is still not working properly, the button is still greyed out. This is on an Ubuntu 10.04 build, that I just updated to 2.7.4. I did this to my Wheezy build that I noticed the same issue with, and it worked fine.


Rick

Please Log in or Create an account to join the conversation.

More
25 Jun 2016 21:28 #76660 by newbynobi
Should work also on Ubuntu, where did you copy the file to?

Please Log in or Create an account to join the conversation.

More
27 Jun 2016 11:20 #76702 by LAIR82
I ended up moving the updated .py file to the /usr/share/pyshared/gladevcp/ directory and it worked, I was trying to move it to the /linuxcnc-dev/lib/python/gladevcp/ directory for some reason,

Oh well, my apologies for the alarm, after a little more perseverance I figured it out.

Rick

Please Log in or Create an account to join the conversation.

Moderators: newbynobiHansU
Time to create page: 0.093 seconds
Powered by Kunena Forum