Issue with gmoccapy file explorer

More
25 May 2016 21:09 - 26 May 2016 14:56 #75083 by tarasko
Two questions.

1. How configure gmoccapy file explorer to open directories/files with single touch? It's not very convenient to do double touch on my touch screen. Single touch is much more faster and simple.
2. As can be seen on attached picture, cursor hovered and clicked on *.ngc file but blue arrow button (located below) seems isn't active. I think it's a file-open button, but why it's disabled? The only way to open file is to make a double touch on this file.

Thanks.
Attachments:
Last edit: 26 May 2016 14:56 by tarasko.

Please Log in or Create an account to join the conversation.

More
25 May 2016 21:31 #75085 by andypugh
This might not be a specific Gmoccapy thing.

Try opening a file-manager window, then Edit->preferences and in "Behaviour" select Single-click to activate a file.

Please Log in or Create an account to join the conversation.

More
26 May 2016 05:33 #75105 by ttontsa
How about ffile explorer view style? Is that possiple to change? Icons, big icons, list, list with details.

Please Log in or Create an account to join the conversation.

More
26 May 2016 14:25 - 26 May 2016 14:58 #75116 by tarasko
I tried, no success.

I don't how it can be related to the current question. Maybe there is. I have also an error each OS reboot.
Attachments:
Last edit: 26 May 2016 14:58 by tarasko.

Please Log in or Create an account to join the conversation.

More
27 May 2016 09:55 #75143 by newbynobi

1. How configure gmoccapy file explorer to open directories/files with single touch? It's not very convenient to do double touch on my touch screen. Single touch is much more faster and simple.


That is not possible, as a selection chaneg will also happen if you do use keyboard arrows, I am not able to handle the difference at the moment.

2. As can be seen on attached picture, cursor hovered and clicked on *.ngc file but blue arrow button (located below) seems isn't active. I think it's a file-open button, but why it's disabled? The only way to open file is to make a double touch on this file.


That Issue has been solved 30.03.2016, but unfortunately the pakages have not been updated yet.
You can replace the existing file on your PC
/usr/share/pyshared/gladevcp/iconview.py

with the attached one (please rename from iconview.txt to iconview.py, you may need root access to do that.

You will solve with that also a second bug, "double clicking in a white space will give an error".

Norbert
Attachments:
The following user(s) said Thank You: tarasko

Please Log in or Create an account to join the conversation.

More
27 May 2016 10:01 - 27 May 2016 10:01 #75145 by newbynobi

How about ffile explorer view style? Is that possible to change? Icons, big icons, list, list with details.

It is not possible at the moment.
Feel free to implement that in the iconview.py file.
I like that idea!

But you can set the icon size as property, from python code or just using the glade editor, editing the gmoccapy.glade file.

Norbert
Last edit: 27 May 2016 10:01 by newbynobi.

Please Log in or Create an account to join the conversation.

Moderators: newbynobiHansU
Time to create page: 0.085 seconds
Powered by Kunena Forum