gmoccapy 2.1.0 has been released

05 Jan 2017 12:48 #85282 by racedirector
racedirector replied the topic: gmoccapy 2.1.0 has been released

racedirector wrote: Quick question.....will this version work with 2.7.8? Was going to download all the required files and do a re-make of the source to get V2+ if it does.

It will not!

If you want to use v2+ with 2.7, you will need to change some code. The main difference is that I changed gmoccapy to support the new Joint/Axis changes from 2.8

If you just want to use the new slider Widgets, that can be done with a reasonable amount of gode modifications.

Because I do support at the moment 3 release versions (gmoccapy in 2.6, gmoccapy in 2.7 and gmoccapy in 2.8) I have not many time to make special wishes come True :-(

I will announce very soon, that gmoccapy in 2.6 will not be supported any more, as users should update to 2.7


Thanks, didn't notice your reply as it was an edit of of my post.

I tried 2.8 but it messed up my ini file to the point of not working so I went back to 2.7. One day I'll try 2.8 again.
09 Jan 2017 00:03 #85495 by Hakan
Hakan replied the topic: gmoccapy 2.1.0 has been released
Had a look at the config files for my lathe but can't find anything obviously wrong.
Switched to Axis and the hick-up wasn't there.
Repeat by jogging, then touch off and enter a number.
After that a mouse-press on the X+/X-/Z+/Z- key buttons is required for further jogging with the joypad.
Commented out ALL joypad settings and the message still comes.
Startup gmoccapy, e-stop off, power on and then press X+/X-/Z+/Z- and it says
"wrong motion mode, change to the correct one". I go and home the axis and again when I
press X+/X-/Z+/Z- and it says "wrong motion mode, change to the correct one"
Perhaps it has something to do with the homing?
At least your comment in suggests that.
I have tried to set up with no homing switches. Intention is that I press "home X"
the axis should home immediately without moving.

But perhaps it is not the homing, it may be the joypad.
Couldn't test that when joypad was uncommented of course.

loadusr -W hal_input -KRAL F310

# Include your custom_postgui HAL commands here
# This file will not be overwritten when you run PNCconf again

loadrt or2 count=2
loadrt mux4 count=1

addf or2.0 servo-thread
addf or2.1 servo-thread
addf mux4.0 servo-thread

setp mux4.0.in0 0
setp mux4.0.in1 25
setp mux4.0.in2 50
setp mux4.0.in3 1000

net remote-speed-slow or2.0.in0 input.0.btn-x
net remote-speed-medium or2.1.in0 input.0.btn-a
net remote-speed-fast or2.0.in1 or2.1.in1 input.0.btn-b

net joy-speed-1 mux4.0.sel0 <= or2.0.out
net joy-speed-2 mux4.0.sel1 <= or2.1.out
net jog-speed <= mux4.0.out

net jog-x-analog <= input.0.abs-y-position
net jog-z-analog <= input.0.abs-x-position

A part from Turner.hal
#  ---HALUI signals---

net joint-select-a
net x-is-homed  
net jog-x-pos   
net jog-x-neg             halui.axis.x.minus
net jog-x-analog          halui.axis.x.analog
net joint-select-b
net z-is-homed  
net jog-z-pos   
net jog-z-neg             halui.axis.z.minus
net jog-z-analog          halui.axis.z.analog
net jog-selected-pos
net jog-selected-neg      halui.axis.selected.minus
net spindle-manual-cw     halui.spindle.forward
net spindle-manual-ccw    halui.spindle.reverse
net spindle-manual-stop   halui.spindle.stop
net machine-is-on
net jog-speed             halui.axis.jog-speed 
net MDI-mode    
10 Jan 2017 22:58 #85594 by Hakan
Hakan replied the topic: gmoccapy 2.1.0 has been released
tested some today. I could get it to work actually,
When I press "Home all" then the joypad works as expected.
But I usually press "Home X" and then "Home Z", don't know why I do it that way really,
and then the X+/X-/Z+/Z- mouse press is needed.

So I will just press "Home all". Easy,
11 Jan 2017 17:56 - 11 Jan 2017 17:57 #85620 by newbynobi
newbynobi replied the topic: gmoccapy 2.1.0 has been released
As already commented out, I am not able to test on real hardware at the moment.
But I think it may be related to the halui pin. Why are you using that pin and not the gmoccapy ones?

Just connect like so:
net jog-x-plus  gmoccapy.jog.axis.jog-x-plus   <=   "pin from your pendant"
Please try and report.

Last Edit: 11 Jan 2017 17:57 by newbynobi.
13 Jan 2017 12:51 #85687 by Hakan
Hakan replied the topic: gmoccapy 2.1.0 has been released
No success, the pin
is a float and the
is a bit so got an error message at startup. The abs-y-position is analog between -1 and 1.

But I think in principle it works using halui, it is just that joint.1 will not get homed when pressing "Home X" and "Home Z". It will get homed when pressing "Home all". Even if the Y axis is not used it is there in the background. That is the difference as far as I can see.
14 Jan 2017 11:25 #85739 by newbynobi
newbynobi replied the topic: gmoccapy 2.1.0 has been released
If you want to use that pin, you should take a look at:


Just take a look at the documents.
Moderators: newbynobi
Time to create page: 0.112 seconds
Powered by Kunena Forum