Campy or camera under gmoccapy/2.7.14?

More
04 Jul 2018 16:08 #113424 by erikg
Hi... I'm running 2.7.14 (as of this morning) on my mill, and I've been using it successfully for a while now.

I'm trying to install a USB microscope type camera for locating features and having problems getting it to work. I tried camview-emc, found it wasn't updated, got pointed at Camview.py in a thread here, and finally tried to install campy.zip from Norbert. I freely admit I probably have 2-3 different versions of packages to open up a camera window partially installed now.

I'm getting errors that make it look like the version of Glade/gtk I'm using (I installed from the live CD) are too new to work with the files in campy.zip - 2.6 for the campy files, 3.0+ for my system.

Has anyone else got this working under 2.7.14? Did you use the campy install script?

I verified my camera works using v4l, I just can't get it to work in gmoccapy.

Erik
More
07 Jul 2018 07:19 #113642 by horizon
Hi Erik,

I get the same error since December 2017 and couldn't fix it. I had to stop using my camera.

I attached the complete error message:

Warning: Spoiler! [ Click to expand ]


Perhaps anyone else can help.

Best regards,
Oliver
More
09 Jul 2018 13:59 #113875 by erikg
Hmm... yours looks a bit like a USB error message, like there is a problem with the particular camera you're using. If it's connected through a hub you might want to try a different method, or maybe a different USB port.

The error message I get says essentially that the python program I'm trying to run is for an older version of Glade, and it won't work without updating.

Erik
More
09 Jul 2018 17:34 #113883 by horizon
Hi Erik,

thank you for your reply.

I checked the camera on an other USB-port, but no success. The problem occurs after the installation of the campy script. The camera and camview work until a tool change is started. The message window for the tool change opens and gmoccapy freezes. Linuxcnc still works in the background (I can still use the handwheel). When I close the message window with "x", Linuxcnc stops and the error message is created.

I thought the problem had something to do with $EMCDISPLAY and GTK, but I really don't understand the code...

Best regards,
Oliver
More
09 Jul 2018 20:05 #113887 by newbynobi
Have you tested without the xhbc handwheel? It seems to get display infos over USB.

Do the freezing ocure also if the camera tab is not in front?

What if you stop the live image before the tool change?

Norbert
More
10 Jul 2018 05:20 #113927 by horizon
Hi Norbert,

thanks for your support.

I will test it without the handwheel tonight.

The same problem was discussed here www.cncecke.de/forum/showthread.php?9932...view&highlight=campy
User "PmK" posted the same error and his config. He doesn't have a XHC-HB04 handwheel in his config.

The freezing occures even with no camera tab and no camera plugged in.

Bests regards,
Oliver
Moderators: newbynobi
Time to create page: 0.090 seconds
Powered by Kunena Forum