Jog slider changes after turtle click.

More
14 Oct 2018 22:56 #118805 by sliptonic
I've been running gmoccapy on machinekit/wheezy for a couple years and it's been great.
I recently upgraded the box to correct some other problems and have a few things still not working right:
I have:
My machine's native unit is in but I use mm in the UI.
MAX_LINEAR_VELOCITY = 1.96 #in/sec = 2987 mm/min
DEFAULT_LINEAR_VELOCITY = .25 = 381 mm/min

When I first launch, the slider is sitting at 381 as expected and the slider will got to 2987. When I toggle to turtle and back, it's all the way at the positive extreme which is now 118. For now, I've hidden the turtle feature but would like to use it.

A second problem I'm experiencing is an error thrown whenever a message is displayed.

Found an error!
The following information may be useful in troubleshooting:

Traceback (most recent call last):
File "/usr/bin/gmoccapy", line 2592, in on_btn_launch_test_message_pressed
self._show_error( ( 13, text ) )
File "/usr/bin/gmoccapy", line 1465, in _show_error
if self._AUDIO_AVAILABLE:
AttributeError: 'gmoccapy' object has no attribute '_AUDIO_AVAILABLE'

Any guidance is much appreciated.
More
15 Oct 2018 01:49 #118809 by cmorley
Being that this in machinekit - do you have any idea what version this would be compared to linuxcnc? I'm not sure machinekit pulls in from linuxcnc anymore.
I think Norbert has version numbers for Gmoccapy is there a way to find that out from the screen?

Norbert (Gmoccapy's author) isn't as active as he once was. But we will try to help.

PS Thanks for your work on freecad path!

Chris M
More
15 Oct 2018 05:18 #118819 by newbynobi
I can do not support machinekit any more. Unfortunately it does not support joint axis support. Or it is handling that different than linuxcnc. I stoped the development for machinekit with the introduction of joint axis in linuxcnc.

As i do support linuxcnc master and 2.7 beeing different releases of gmoccapy i unfortunately can not efort any more time for a third version of gmoccapy.

The mentioned errors have been solved in linuxcnc.
If you mention the release number of gmoccapy you use, i can take a look what I changed.
Just open the settings page an look for the release details in the bottom button area.

Norbert
More
15 Oct 2018 16:53 #118836 by sliptonic
Thanks Norbert. Anything you can do is appreciated. My version is 1.5.6.5
More
28 Oct 2018 22:06 #119574 by newbynobi
I am able to reproduce the slider error also in the linuxcnc release, i will look at it and correct that error!
More
29 Oct 2018 19:11 #119608 by newbynobi
Hallo Sliptonic,

I just pushed a fix for gmoccapy 1.5.X for the turtle button and an error I found in max vel slider handling.

It is here .

As you are in machinekit, you will need to add the changes by your own to the file /usr/bin/gmoccapy
that is not to hard.

Norbert
The following user(s) said Thank You: sliptonic
Moderators: newbynobi
Time to create page: 0.073 seconds
Powered by Kunena Forum