gmoccapy freeze at toolchange

More
05 Nov 2019 17:56 #149629 by billykid
Hello,
I have a configuration with tool change and probe used to drill some printed circuits perfectly.
after installing nativecam and campy both working I realized that the "insert tool .... and click ok" window remains locked. the program continues to do the same but cannot be stopped.
use debian stretch with linuxcnc 2.7.14.
Thanks in advance
mauro

Please Log in or Create an account to join the conversation.

More
05 Nov 2019 21:17 #149654 by newbynobi
Please disable probe and try again. If that does work, it is a probe problem, otherwise post your config, as it will be a config prble, most probaly wkth toll change and tool changed hal pin

Norbert

Please Log in or Create an account to join the conversation.

More
06 Nov 2019 10:10 - 06 Nov 2019 10:39 #149682 by billykid
Thanks Norbert,
I tried to disable the probe but it blocks the same .. I only added Campy non nativecam I was wrong to write, the one on another configuration with axis. Gmoccapy before campy first went perfectly.
I attach the ini file, if you need more, tell me.
thanks
Mauro
Attachments:
Last edit: 06 Nov 2019 10:39 by billykid.

Please Log in or Create an account to join the conversation.

More
07 Nov 2019 11:34 #149835 by billykid
practically the tool change and the probe work, only the dialogue window "please insert tool...." remains frozen, but the machine continues to work regularly but no command answers any more and the forced closing of the window completely closes linuxcnc

Please Log in or Create an account to join the conversation.

More
08 Nov 2019 14:49 #149920 by newbynobi
Is this a auto toolchange, or a manual one?

What happen if you enter in MDI mode a toolchange comand like

T3 M6

Norbert

Please Log in or Create an account to join the conversation.

More
08 Nov 2019 15:30 #149923 by billykid
m6t2 works perfectly. the dialog box remains locked, this after installing nativecam. now I am reinstalling everything clean also because I want to use wheezy even if old at 8 khz is better than stretch.
the stretch installation works perfectly but for the 5i23 I think the old kernel is better since it also has better latency.
thanks also for the good work
regards
Mauro

Please Log in or Create an account to join the conversation.

More
10 Nov 2019 18:52 - 10 Nov 2019 18:59 #150074 by billykid
I reinstalled everything and it was not nativecam as I thought .. the error occurs after installing Campy
Attachments:
Last edit: 10 Nov 2019 18:59 by billykid.

Please Log in or Create an account to join the conversation.

More
11 Nov 2019 12:30 - 11 Nov 2019 15:33 #150104 by billykid
Hello
I have other info, practically enough that it goes in the setting ----> advanced setting
> launch text message to get the usual block. it confirms to me that it is the message that blocks everything. not the tool change that works perfectly. this after installing

and this problem is the same
campy. www.forum.linuxcnc.org/gmoccapy/34855-ca...occapy-2-7-14#113883
Last edit: 11 Nov 2019 15:33 by billykid.

Please Log in or Create an account to join the conversation.

Moderators: newbynobi
Time to create page: 0.093 seconds
Powered by Kunena Forum