Gmoccapy Jog Buttons Dissappears With Dual Axis Joint

More
16 Jan 2020 04:14 #154994 by AgentWD40
Linux 2.9 pre.

I've noticed that if I set up a basic config using pncconf, that if the config is using a tandem motor axis that the jog buttons won't be available in the gmoccapy gui. If I make the same config, this time just leaving out that tandem joint, the jog buttons appear on screen as expected.

Please Log in or Create an account to join the conversation.

More
01 Feb 2020 03:30 #156284 by Gaunt1969
Same here I just upgraded to master branch got things set up, started Gmocappy, and no jog buttons.

Please Log in or Create an account to join the conversation.

More
01 Feb 2020 21:56 #156325 by Gaunt1969
Duh!
What was I thinking.
Been up to long.

Please Log in or Create an account to join the conversation.

More
01 Feb 2020 23:39 #156329 by tommylight

Gaunt1969 wrote: Duh!
What was I thinking.
Been up to long.


???????????????????

Please Log in or Create an account to join the conversation.

More
02 Feb 2020 00:55 #156337 by Gaunt1969
Tommy
When I was upgrading my system to master, after I started gmoccapy and seen the same issue agent did. It did not dawn on me how linuxcnc was treating each motor as a separate joint and required a home befor it would dispay the buttons.
I had been working on this thing to long
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

More
02 Feb 2020 00:59 #156338 by tommylight
Thank you for explaining that.

Please Log in or Create an account to join the conversation.

Moderators: newbynobi
Time to create page: 0.087 seconds
Powered by Kunena Forum