Spindle override problems after update to 2.7

More
12 Sep 2023 23:35 #280581 by Peter FP4
Hi, since this is my first post in this Forum a few Words to myself and my Linux CNC Situation:
My Name is Peter I am from Germany and I entered the CNC world maybe around 7 years ago by buying an old Deckel FP4 AT together with a friend. After trying to fix the old Sinumeric Controller for a year or so we decided to go ahead and convert to Linux CNC. We kept as much a possible of the old stuff and just replaced the brain box amplifier Motors Scales Solenoids ... all that was kept to keep the costs and the work low. After a getting used to Linux CNC we were able to get the Machine runnig stec by step, that took a couple of years as well and is still not finished. However, for the last two or three years the Machine has been in a usable condition and that slowed the further implementation of stuff down even more. One thing I wanted to do for a long time was to try non ridged tapping with a chuck elastic in length. So I started to work on this a few weeks ago and found out that Linux CNC could not really deal with the G84 command in the 2.7 version and that the newer 2.8 version should be better at that. Since we never really did any updates since we started and always thought: never change a running system, we decided to use a new SSD and install Linux CNC from scratch and have the old SSD as a Backup. After the installation we imported our configuration and did the automatic "transformation" after dealing with error codes that were mainly changes in variable naming for an hour or so (that was way faster than I expected) we were able to start the program and everything seems to work more or less...

Now to my Problem:
When starting Linux CNC I get an Error message not the usual one like when missing a letter in a variable or so, but a different one, that seems to come directly from gmocapy. It gives me the following debugging Information:

 

Found an error!
The following Information may be usefull in troubleshooting:

Traceback (most recent call last):
 File "/usr/lib/python2.7/dist-packages/gladevcp/speedcontrol.py”,line171, in expose self.draw widget()File "/usr/lib/python2.7/dist-packages/gladevcp/speedcontrol.py”,line187, in_draw_widgetPercentage = (self._value-self._min)*100/(self._max-self._min)ZeroDivisionError: float division by zero

 
When gmocapy is working then I get random popups that are empty. They show up when turning the machine on a couple of times when running a program… and the screen freezes completely when they open but the machine keeps working. 

 

So I dug a little into that stuff looked at the files and so on and I found out that this behavior is somehow related to the Spindle override min max value. I had set those both to 1 since I don’t want any override because this can initiate a gear change while the machine is running or even milling however when the machine switches gear first thing it does is stop the spindle so doing it while milling is does not end well.For tests I went ahead and set the min to 0.5 and the max to 1.5 in the ini file. This changed the behavior, Linux cnc would not start up any more and I had to abort it were I got the following error message:   

Debug file information:Note: Using POSIX realtime (classicladder:5161): Gtk-CRITICAL **: 01:44:34.414: IA__gtk_widget_get_parent: assertion 'GTK_IS_WIDGET (widget)' failed/usr/bin/gmoccapy:312: GtkWarning: Invalid icon size 48   self.widgets.window1.show() (gmoccapy:5171): GtkSourceView-CRITICAL **: 01:44:36.012: gtk_source_language_manager_set_search_path: assertion 'lm->priv->ids == NULL' failedWaiting for component 'py_wechsler' to become ready......................................................................................Traceback (most recent call last):  File "./python/py_wechsler.py", line 225, in <module>    hal.set_p("toolchanger.hal_led_arm_draussen","0")RuntimeError: pin not found/usr/bin/linuxcnc: Zeile 896:  5171 Getötet                $EMCDISPLAY -ini "$INIFILE" $EMCDISPLAYARGS $EXTRA_ARGS51365168Stopping realtime threadsUnloading hal componentsRTAPI_PCI: Unmapped 65536 bytes at 0x7f656aa4a000Note: Using POSIX realtime

 It seems something is screwed up with the widget size but I don’t know why and how to fix it. However this seems to stop the loading of gmocapy, because of the loading of gmocapy being stopped the embedded glade panels do not get loaded  and therefore the embedded python script py_wechsler (that is for the toolchanger) cant set the LED pin that is created by the embedded glade panel when it gets loaded. In my embedded python scripts I have a delay at the beginning to make sure ale the bins are there when the script starts working and I set that to 10s on the py_wechsler for troubleshooting but It does not seem to change anything.After that I read the documentation and tried the values 0.5 and 1.2 that were given there and this caused the same behavior than 0.5 and 1.5. Next I commented out the lines in the ini completely and everything worked and the spindle override was from 10 to 100 percent as described in the documentation as default. So now I need to find a way to disable the spindle override or modify something so that min1 and max1 works.  Maybe this caused a problem in 2.7 already, but the error messages are new? When gmocapy starts with the min and max being 1 it does not show the override slider in 2.8 and I can not remember if it did in 2.7.I will try to attach everything I think is needed to follow my problem If you need something else please let me know.

By the way I already tried the G84 and it seems to work fine so I am very excided to try it out in material not just in air.  

Please Log in or Create an account to join the conversation.

More
13 Sep 2023 04:44 #280591 by newbynobi
Hallo Peter,

This is Norbert also from Germany (31171 Nordstemmen ) and we'll come to this lovely community.
First never et Min and Max to the same values, neverthereless you have opened a bug with your comment, as the "Division by zero" should not ocur.

I had a quick look at the files you posted.
First  think I noticed is that you load your glade files in the INI file without any added parameter. That causes very often race conditions, that could leas to the errors you are seeing.

Load the glade panel with the documented parameters, like:
gladevcp -c gladevcp -u hitcounter.py -H manual-example.hal manual-example.ui
- c = name of the component
- u = the related python scribt to add additional behavior as pins adding, theme loading etc,
- H = the Hal file to be loaded after the panel has been realized, so all Hal connections to the panel belong here!

Norbert

Please Log in or Create an account to join the conversation.

More
18 Sep 2023 00:13 #281030 by Peter FP4
Hello Norbert, 
I have allready been in contact with you a couple of years ago via the CNC Ecke forum. I tryed to implement your suggestions on Friday but I was not really succesfull yet. When I realized that I probably ned to do some more research in the whole glade thing I tryed to just comment al the Glade panels out. This worked in a way that I got nor more pin not found errors but there was still the size error and linux cnc would not start. I am woundering if i should just reinstall it maybe something got screwed up permanently by the zero division. However the next three weeks I will not have time to deal with this stuff and I have to do some tiding up to get all the conections in the hal coresponding with the glade file and so on, so it will take some time till I can tell You more. I really like to have the conections organized that way, because it makes  everything more structured. Most of my programming is just copieing diferent bits and pieces together and adapting them and as soon as something works it just gests used.

Regards Peter

 

Please Log in or Create an account to join the conversation.

Moderators: newbynobiHansU
Time to create page: 1.272 seconds
Powered by Kunena Forum