Use NativeCAM as a deb package now

More
10 Sep 2019 13:52 #144700 by Dimitrios
Fern, first of all, many, many thanks for your great effort. Hope not to bother you with noob questions but:

Being fairly ignorant in Linux, for some years i am using LinuxCNC with good results. yesterday I downloaded and installed version 2.7.14, and, for the first time, tried to install NativeCAM, following the procedures on the first page of this thread. all I get is:

'Detected operating system as debian/wheezy.
Checking for curl...
Installing curl...
Reading package lists...
Building dependency tree...
Reading state information...
Package curl is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'curl' has no installation candidate
Running apt-get update... done.
Installing debian-archive-keyring which is needed for installing
apt-transport-https on many Debian systems.
Installing apt-transport-https... done.
Installing /etc/apt/sources.list.d/FernV_NativeCAM.list...ncam_debsetup.txt: line 115: curl: command not found

Unable to run:
curl packagecloud.io/install/repositories/Fer...wheezy&source=script

Double check your curl installation and try again.


I am lost. Synaptic ignore any reference to curl itself, only shows libcurl. i downloaded the curl package, but can't manage to synaptic use it. What I am missing here?

I really appreciate some guidance.

BR

Dimitrios
'

Please Log in or Create an account to join the conversation.

More
10 Sep 2019 17:25 #144720 by Gene1934
I've had similar. Go ahead and install libcurl, ISTR it works somehow

Cheers, Gene Heskett
--
"There are four boxes to be used in defense of liberty:
soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
Genes Web page < geneslinuxbox.net:6309/gene >
The following user(s) said Thank You: Dimitrios

Please Log in or Create an account to join the conversation.

More
10 Sep 2019 17:34 #144721 by Dimitrios
Thanks Gene1934! I'll try it and report back.

Regards,

Dimitrios

Please Log in or Create an account to join the conversation.

More
10 Sep 2019 17:41 #144722 by Dimitrios
Well, sinaptic informs me that I have libcurl3-gnutls installed, version 7.26.0-1+wheezy25+deb7u1 which is the latest version.

what now? My ignorance in Linux is troubling me. Do I have to somehow force a new install, using apt-get?

You can point me to some docs, do not want to be a lazy guy!

thanks again, and regards.

Dimitrios

Please Log in or Create an account to join the conversation.

More
10 Sep 2019 17:58 #144727 by Gene1934
Maybe some else, even Fern can help. wget does essentially the same thing but probably needs different cli options. So the scripts that use curl might be editable to use wget.

I think I read someplace quite a while back that curl was using an out of date security library, Its dirt I haven't kicked around much, and the oldtimers memory fades too fast, it will be 85 years old next month. Sorry I can't be more specific.

Gene1934

Cheers, Gene Heskett
--
"There are four boxes to be used in defense of liberty:
soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
Genes Web page < geneslinuxbox.net:6309/gene >
The following user(s) said Thank You: Dimitrios

Please Log in or Create an account to join the conversation.

More
10 Sep 2019 18:21 #144728 by Dimitrios
Thank you, Gene!

I am searching around, and, if I find a solution, i will post it here.

My mom is 84, and still work as a translator and consultant for language and literature works. She has a PhD in that area.

You are perfectly fine, believe me. Still go a long stretch!

Best regards

Dimitrios

Please Log in or Create an account to join the conversation.

More
10 Sep 2019 20:36 #144740 by okiejim
That curl error was exactly what was happening to me with unbutu lucid. I finally gave up and got the latest debian 9 live dvd and was able to load up NativeCam. I really love NativeCam and will continue to us it as my new go to for CAM.

Please Log in or Create an account to join the conversation.

More
10 Sep 2019 21:02 #144743 by BigDo
try
sudo apt-get install curl

Please Log in or Create an account to join the conversation.

More
11 Sep 2019 12:56 #144816 by Dimitrios
okiejim, you installed debian 9 and native cam, but not linux cnc?

BigDo, I tryed apt-get today and go the same. No curl librarie to install.

It is only me, or there are other people with this problem?

I will search more today, but I am lost.

Regards,

Dimitrios

Please Log in or Create an account to join the conversation.

Time to create page: 0.125 seconds
Powered by Kunena Forum