NativeCam as embedded tab ???

More
14 Nov 2017 04:50 #101759 by Roguish
Finally have NativeCam installed, and working. Just don't have the screen room to have it as a panel.
What the heck are the .ini lines to have it as a tab in axis?
thanks.

Please Log in or Create an account to join the conversation.

More
14 Nov 2017 04:59 #101760 by FernV
Replied by FernV on topic NativeCam as embedded tab ???

Roguish wrote: ...What the heck are the .ini lines to have it as a tab in axis?

$ ncam -h
This will tell you how to do it. Start with removing ALL "NativeCAM required item" in your ini file

Fern

Please Log in or Create an account to join the conversation.

More
16 Nov 2017 23:53 - 16 Nov 2017 23:56 #101911 by Roguish
thanks for the message. I have done just that, removed all references to NCAM in the .ini,

I added 'NCAM_DIR = ncam' in the [DISPLAY] section of the .ini, and added the lib entry.
and I get an NCAM screen with no linuxcnc.

and ran 'ncam -i axis3.ini -c mill -t'
when I run 'linuxcnc axis3.ini' I get linuxcnc with no NCAM

The 'help' says ' -t | --tab with axis and gmoccapy it will be in a tab'

I am running master, with axis, not gmocappy.
I would like to see NCAM as a tab in axis.

What are the .ini file lines to add to get this?
Last edit: 16 Nov 2017 23:56 by Roguish.

Please Log in or Create an account to join the conversation.

More
17 Nov 2017 04:16 - 17 Nov 2017 04:17 #101916 by Roguish
Well, getting there. Sure could use just a little help here Norbert.

[DISPLAY]
# required NativeCAM item :
NCAM_DIR = ncam
EMBED_TAB_NAME = NativeCAM
EMBED_TAB_COMMAND= gladevcp -c gladevcp -x {XID} -U --catalog=mill /usr/share/linuxcnc/aux_gladevcp/NativeCAM/ncam.ui



Attachments:
Last edit: 17 Nov 2017 04:17 by Roguish.

Please Log in or Create an account to join the conversation.

More
17 Nov 2017 16:29 #101946 by FernV
Replied by FernV on topic NativeCam as embedded tab ???

Roguish wrote: thanks for the message. I have done just that, removed all references to NCAM in the .ini,

I added 'NCAM_DIR = ncam' in the [DISPLAY] section of the .ini, and added the lib entry.

These are inserted automatically when running 'ncam -i axis3.ini -c mill -t'

...and I get an NCAM screen with no linuxcnc.

This is correct

and ran 'ncam -i axis3.ini -c mill -t'

NativeCAM only and it updated your 'axis3.ini' file if it prints in the terminal it succeded and it did as shown in your last post

when I run 'linuxcnc axis3.ini' I get linuxcnc with no NCAM

The 'help' says ' -t | --tab with axis and gmoccapy it will be in a tab'

I am running master, with axis, not gmocappy.
I would like to see NCAM as a tab in axis.

You have done everything correctly.
The problem is with 'master'. I had someone email me (instead of posting here) how he did it. I will search his message and post it.
Unfortunately, I did not understand what he meant.

Regards
Fern

Please Log in or Create an account to join the conversation.

More
17 Nov 2017 22:01 #101954 by Roguish
thank you. I look forward to the solution.

Please Log in or Create an account to join the conversation.

More
17 Nov 2017 23:07 #101955 by FernV
Replied by FernV on topic NativeCam as embedded tab ???

Roguish wrote: EMBED_TAB_COMMAND= gladevcp -c gladevcp -x {XID} -U --catalog=mill /usr/share/linuxcnc/aux_gladevcp/NativeCAM/ncam.ui


replace your line with this one :
EMBED_TAB_COMMAND = gladevcp -x {XID} -U --catalog=mill /usr/share/linuxcnc/aux_gladevcp/NativeCAM/ncam.ui

Fern

Please Log in or Create an account to join the conversation.

More
18 Nov 2017 15:15 #101976 by Roguish
THAT DID THE TRICK !!!!
THANKS.

Please Log in or Create an account to join the conversation.

More
23 Nov 2017 22:27 #102278 by Roguish
Fern, thanks again. 1 question. I always use OPEN_FILE in my .ini to load the same gcode at start up. now with ncam loaded in axis, OPEN_FILE does not work. An NCAM file opens instead.
How can I get my favorite gcode file to open with OPEN_FILE ???

Please Log in or Create an account to join the conversation.

More
24 Nov 2017 06:17 #102283 by FernV
Replied by FernV on topic NativeCam as embedded tab ???

Roguish wrote: ...I always use OPEN_FILE in my .ini to load the same gcode at start up. now with ncam loaded in axis, OPEN_FILE does not work. An NCAM file opens instead.
How can I get my favorite gcode file to open with OPEN_FILE ???

On every change, NativeCAM will generate a new file and load it in lcnc. I do not know what is in your file but I guess it is some configuration. You will edit Utilities/Preferences and enter what you need there. It is also possible to include your custom file but I do not think it is appropriate in your case. Post you file here and I will recommend what to do.

Fern

Please Log in or Create an account to join the conversation.

Time to create page: 0.136 seconds
Powered by Kunena Forum