error message

More
25 Mar 2018 19:01 #107835 by skrap58
error message was created by skrap58
Hello,

I keep getting this error message when starting linuxcnc. Start from terminal attached with a screen shot of linuxcnc.

As always thanks for any and all help.

Bill

File Attachment:

File Name: terminalstart.ngc
File Size:2 KB

File Attachment:

File Name: terminalstart.ngc
File Size:2 KB
Attachments:

Please Log in or Create an account to join the conversation.

More
25 Mar 2018 20:47 #107842 by Todd Zuercher
Replied by Todd Zuercher on topic error message
That is the result of either having a base-thread speed too fast for the latency of the computer or a computer that doesn't have good enough latency.

Please Log in or Create an account to join the conversation.

More
26 Mar 2018 10:45 #107894 by skrap58
Replied by skrap58 on topic error message
Hi Todd and thank you for the reply. I should have been more specific. This is the error which is the thorn in my side.

/usr/share/linuxcnc/aux_gladevcp/NativeCAM/ncam.py:2644: GtkWarning: IA__gtk_accel_label_set_accel_closure: assertion 'gtk_accel_group_from_accel_closure (accel_closure) != NULL' failed
mi = _action.create_menu_item()

It comes from starting linuxcnc from the terminal.

The realtime error happens no matter what I set the latency at. Once closed it doesn't seem to bother anything. In nativecam some subroutines work and others don't. Just trying to get things tuned so everything works as it should. Also my screen shot was not what I intended. My apologies.

Thanks

Bill

Please Log in or Create an account to join the conversation.

More
26 Mar 2018 14:23 #107900 by Todd Zuercher
Replied by Todd Zuercher on topic error message
That looks like a problem with your Gladevcp. But I couldn't tell you exactly what without seeing your files to look for the problem. (Something to do with your H bar for your spindle speed.) A better programmer might be able to tell you exactly what your problem is just from that error message, but not me.

Please Log in or Create an account to join the conversation.

More
26 Mar 2018 21:18 #107924 by skrap58
Replied by skrap58 on topic error message
/usr/share/linuxcnc/aux_gladevcp/NativeCAM/ncam.py:2644: GtkWarning: IA__gtk_accel_label_set_accel_closure: assertion 'gtk_accel_group_from_accel_closure (accel_closure) != NULL' failed
mi = _action.create_menu_item()

Still getting the same message every time I start Linuxcnc. I have tried deleting the ncam directory and restarting but it does not do any good. Any help would be appreciated. Nativecam freezes linuxcnc when i try to run the basic spacer.xml example. I wonder if this has anything to do with my hal file? I have recently added a water cooled spindle and that is when this problem started. Please let me know what files need to be looked at and I will post them also.

Thank you for your continued support.

Bill

Please Log in or Create an account to join the conversation.

More
27 Mar 2018 00:19 - 27 Mar 2018 00:20 #107935 by Todd Zuercher
Replied by Todd Zuercher on topic error message
I'm pretty sure it has nothing to do with your ncam installation. It is something wrong with your spindle speed indicator. Which would make sense if you say your problem started when you added a new spindle (and probably the speed indicator.)
Last edit: 27 Mar 2018 00:20 by Todd Zuercher.

Please Log in or Create an account to join the conversation.

More
27 Mar 2018 12:48 #107954 by skrap58
Replied by skrap58 on topic error message
Thanks Todd,

I will have a look at that this afternoon. Maybe the custom.xml is causing some chaos.

Bill

Please Log in or Create an account to join the conversation.

More
27 Mar 2018 20:19 #107996 by skrap58
Replied by skrap58 on topic error message
/usr/share/linuxcnc/aux_gladevcp/NativeCAM/ncam.py:2644: GtkWarning: IA__gtk_accel_label_set_accel_closure: assertion 'gtk_accel_group_from_accel_closure (accel_closure) != NULL' failed
mi = _action.create_menu_item()

I have deleted the custompanel.xml and the custompostgui.hal files and still experience the same error messge posted above. I'm stumped. Any Ideas?


Bill

Please Log in or Create an account to join the conversation.

More
27 Mar 2018 20:24 #107997 by skrap58
Replied by skrap58 on topic error message
This is the section that seems to be causing the problem in ncam.py

def create_menubar(self):
def create_mi(_action, imgfile = None):
(line 2644) mi = _action.create_menu_item()
if imgfile == None :
mi.set_image(_action.create_icon(menu_icon_size))
else :
img = gtk.Image()
img.set_from_pixbuf(get_pixbuf(imgfile, add_menu_icon_size))
mi.set_image(img)
return mi

Please Log in or Create an account to join the conversation.

More
28 Mar 2018 11:48 #108029 by skrap58
Replied by skrap58 on topic error message
I'm at the point where I am considering a complete delete and reinstall of linuxcnc and nativecam. I was hoping to avoid that but, I need my machine running. Does anyone have any ideas how I might fix this without the above mentioned steps?

Bill

Please Log in or Create an account to join the conversation.

Time to create page: 0.132 seconds
Powered by Kunena Forum