setting up for Parallel port Tutoral Part 3 with PathPilot version 2

More
09 Jul 2017 06:50 #95528 by JANNOVV
HI,
I'm trying a lathe on a parallel port.
Tried several times but no luck.
Please example hall and ini for lathe PP on a parallel port.
Thanks, Jan.

Please Log in or Create an account to join the conversation.

More
11 Jul 2017 14:05 #95660 by andypugh
Can you give a more specific description of what is not working?

Please Log in or Create an account to join the conversation.

More
02 Oct 2017 14:44 #99767 by czu774
Hi,
I'm a beginner in Linux, but I find your tutorial very useful.
Thank you for the great job.
I have an cnc lathe retrofitted and I'm using my own Visual Basic programs and Mach3.
Now I want to tray the Pathpilot on parallel port.
I followed the instructions an I used the files from archive for the mill_pp example; everything was fine.
Do you have files for lathe_pp also?

Cezar.

Please Log in or Create an account to join the conversation.

More
12 Dec 2017 16:22 #103007 by emptyhb
Hi, I've trouble with config limit in pathpilot using parallel port

How to edit hal file for pathpilot accept signal from parallel port - pin?

Thanks!

Please Log in or Create an account to join the conversation.

More
26 Jan 2018 14:09 #105039 by slipalong
Ive followed the tutorial and now have PP running ok, I have been using LCNC 2.7.11 for some months on a small mill (BF30 type).
Im moving from LCNC and Axis to PP mainly because well its ugly!

As I understand it I need to cut and paste lines from my working hal and ini files into the exampled kindly provided by Blacksheep.

Could anyone let me know what needs to be moved / copied please.

Please Log in or Create an account to join the conversation.

More
20 Feb 2018 23:18 #106259 by narrab
Thank you for posting this PathPilot for Parallel Port Tutorial. I followed the instructions using v 1.9.3 Everything worked except I would get a jog error when setting the Estop. I read else where on this forum this was caused because the Machine OK was not set. So I by trial and error I now have this working by changing the Hal file. I have attached the Hal file that works for me to help others who follow this tutorial in the future.

File Attachment:

File Name: mill_pp.hal
File Size:6 KB
Attachments:

Please Log in or Create an account to join the conversation.

More
24 Feb 2018 03:46 #106421 by narrab
I finally tried to hook up my stepper motors/ motor drivers to my BOB. While the Pathpilot is running and the x coordinates move with the Shuttlexpress, I am not getting any motor movement. By the Pathpilot by Tormach logo it says Frank SIM. Does this meant that I am in simulation mode? I have tried to view the signals on the Halscope and the Xstep does not show a signal when I move attempt to jog the x motor.

Any Ideas?

Please Log in or Create an account to join the conversation.

More
13 Feb 2019 18:13 #126367 by slipalong
Anyone managed to get PP2 working with a parallel port. Been trying for 2 day without success.

Please Log in or Create an account to join the conversation.

More
02 Jul 2019 19:36 #138427 by davidimurray
Hi

I just received my PPV2 USB stick a couple of days ago and today set about installing. Eventually it will be for my lathe, but in the first instance I am following the mill guidelines to allow me to confirm I can get a working setup.

I've been following the guide, but have come across a strange problem - the config_file.txt does not seem to exist/get created.
If I choose a config, I then get an error that the machine cannot be connected to. The PC then shuts down and when I restart, there is no config_file.txt

I've also tried creating an empty file, named config_file.txt that contains one line of ~/tmc/configs/tormach_mill/mill_pp.ini

However when I boot the PC it just boots into an empty screen with the backdrop showing and PP does not start. I've tried a couple of times now and same result every time/

Any help would be much appreciated

Please Log in or Create an account to join the conversation.

More
02 Jul 2019 23:48 - 02 Jul 2019 23:48 #138464 by smgvbest
This guide is for V1 of PP, V2 there is several other posts on getting V2 up and running and the difference in the config files. just search for version 2 here in this forum and you'll find what you need.

You must enable EFI to boot and run the USB Drive correctly
Last edit: 02 Jul 2019 23:48 by smgvbest.

Please Log in or Create an account to join the conversation.

Moderators: cncbasher
Time to create page: 0.130 seconds
Powered by Kunena Forum