Probe Basic Tool Change Buttons Doesn't Work

More
11 Oct 2020 11:55 - 11 Oct 2020 12:01 #185701 by harindugamlath
I'm Having some trouble with tool change buttons and other custom buttons on Probe Basic.

For Example if I click M6 G43 on the main screen I get an error saying No such filer or directory. See the image below.
This happens for every other button that requires some operation.







Are these custom macros that we need to write ourselves? or do they come with probe basic? I have seen videos of ATC forwards backwards buttons operation with probe basic. But all of that stuff is saying its missing something (ATC Buttons say unknown M code). MDI works flawless. That's what I have been using.

If we need to write these can anyone kindly guide me to find a template. I'm doing manual tool changes right now.

I'm pretty new to Linuxcnc. I just started my mill conversion with axis and switched over to probe basic. My mill is an old okuma. All the others work as it should and the mill is surprisingly accurate. If I can get these to work it will be a real time saver.

Any help is appreciated.
Last edit: 11 Oct 2020 12:01 by harindugamlath.

Please Log in or Create an account to join the conversation.

More
11 Oct 2020 14:54 #185718 by tommylight
There should be "configs" between the "LinuxCNC" and "nc_files" folders in the path in the ini file.

Please Log in or Create an account to join the conversation.

More
11 Oct 2020 16:11 #185726 by harindugamlath
I didn't get it. Can please explain a bit. My nc files folder is empty.

Please Log in or Create an account to join the conversation.

More
13 Oct 2020 01:45 #185905 by harindugamlath

Please Log in or Create an account to join the conversation.

More
14 Oct 2020 16:10 #186105 by harindugamlath
If anyone sees this at least give me a good basic idea on whats happening or point me to someone who could offer some help. I really like probe basic. but its getting harder when its your first time with linux and there is no other place to ask.

Please Log in or Create an account to join the conversation.

More
14 Oct 2020 16:58 #186106 by tommylight
Upload your config folder, give us something more to chew on.
"does not work" does not explain a lot.

Please Log in or Create an account to join the conversation.

More
14 Oct 2020 17:23 #186110 by harindugamlath
Ok Sure. it's almost midnight here. I'll post it when I get to my workshop.
I thought I explained it a bit more than that. Those files that are requested by the button press are not there. Do they come with probe basic? Do I need to write those files ? Please give me an answer to that.

Please Log in or Create an account to join the conversation.

More
14 Oct 2020 17:32 #186112 by tommylight
Not sure about what buttons or files, but compress the config folder as is and upload it here, maybe someone can help.
I do not have a mill (yet) so i am not using it, hence i am just trying to help as much as i can.
QtPyVCP should have a status window, what are the errors there when you try to change tools?
The following user(s) said Thank You: harindugamlath

Please Log in or Create an account to join the conversation.

More
14 Oct 2020 17:49 #186115 by harindugamlath
Thanks really appreciate it. I have attached the images of the errors. For some reason are not showing up? I'll reattach them if needed. They basically say the requested file is not there. for M6 G43 it says "No such file or directory " "M6_tool_call_main_panel.ngc"

I truly don't want to ditch Linux cnc and go for a standalone controller because the machine works flawlessly. Its an old okuma super rigid boxway machine and the the test cuts are within 10um repeatability.


Attachments:

Please Log in or Create an account to join the conversation.

More
14 Oct 2020 18:13 #186116 by rodw
The error says that a gcode file is missing and tells you exactly the file name and the location. So have you looked for that file? I Would say all you need to do is put the correct file where linuxcnc is looking for it.
The following user(s) said Thank You: harindugamlath

Please Log in or Create an account to join the conversation.

Moderators: KCJLcvette
Time to create page: 0.174 seconds
Powered by Kunena Forum