LinuxCNC 2.9, Python 3 and Probe Basic

More
15 Oct 2021 12:26 #223196 by spi
I have a simple issue trying to get everything running in a pure Python 3 / LinuxCNC 2.9 environment:

1) If I install qtpyvcp using pip install qtpyvcp I get v0.3.19 which is written in Python 2 and fails on running LinuxCNC with probe_basic.ini (error is basestring in opt_parser.py)
2) If I clone qtpyvcp repo and install using pip install --editable . then the version number reported by pip is python3-master-gc11c2841 which is incompatible with the qtpyvcp >= 0.3.9 requirement.
3) I can force the installation of PB from python3 branch by doing pip install probe-basic --no-dependencies --editable .
4) After this I can run editvcp mini without errors but editvcp probe-basic fails with qtpyvcp >= 0.3.9 requirement.
5) LinuxCNC also fails with qtpyvcp >= 0.3.9 requirement.

So, I guess my question is how can I make PB believe that the installed qtpyvcp should be a compatible version?

Thanks!




 

Please Log in or Create an account to join the conversation.

More
22 Oct 2021 10:42 #223900 by spi
Ended up editing setup.py in qtpyvcp to remove the version reported by versioneer and replacing it with a hardcoded '0.4.0'. I'm sure there's better ways of achieving it but at least it got me past this issue.

Please Log in or Create an account to join the conversation.

More
28 Oct 2021 18:23 - 28 Oct 2021 18:25 #224604 by Joco
At the moment I do not believe the packaged probe basic installer is for py3.  It's for py2.   The py3 version is only available by cloning the repo and checking out the python3 branch.  Then doing your pip install -e .  in that directory.    If you have installed a previous version don't forget to remove/uninstall it via pip.

Cheers - J.
Last edit: 28 Oct 2021 18:25 by Joco.

Please Log in or Create an account to join the conversation.

Moderators: KCJLcvette
Time to create page: 0.098 seconds
Powered by Kunena Forum