Error while working with python3 and qtpyvcp

More
11 Nov 2021 11:50 #226094 by mfgstudio
I am trying to use qtpyvcp with python3 but I am getting errors on this thing. I did everything and run make html command, it gives me errors and also successfully finishes its process. I thought nothing was wrong but when I am trying to run editvcp it gives me ValueError: PyCapsule_GetPointer called with incorrect name and says me that autdoc needs qt12, not qt11.3 (or sth. like that). But before it says autodoc: failed to import class 'hal plot.Hal Plot' and more errors. At last, I can't get my linuxcnc widgets and thats what I need now. What is this problem, I am doing everything that is written. I really don't understand the problem man. 
Warning: Spoiler!
Attachments:

Please Log in or Create an account to join the conversation.

More
11 Nov 2021 12:17 - 11 Nov 2021 15:41 #226095 by hardware_crash
forum.linuxcnc.org/qtpyvcp/44193-probe-b...es-please-start-here

please provide more information like written in the Thread above.

This might already be your answer: autdoc needs qt12, not qt11.3 

Lukas
Last edit: 11 Nov 2021 15:41 by hardware_crash.
The following user(s) said Thank You: mfgstudio

Please Log in or Create an account to join the conversation.

More
11 Nov 2021 17:55 #226123 by Joco
Ditto per Lukas’s comment. 

So you are aware, with the move to py3 many of the team are running Debian 11 or equivalent distro to have a clean/untainted py3 environment.  Some are even flirting with arch linux.  The point being these tend to give you qt15.x and solve a bunch of dependency issues that plague trying to move older OS’s forward. 

Cheers. 

 
The following user(s) said Thank You: tommylight, mfgstudio

Please Log in or Create an account to join the conversation.

More
13 Nov 2021 21:47 #226371 by mfgstudio
Okay, next time I will do all the written things. Thank you :)

Please Log in or Create an account to join the conversation.

More
13 Nov 2021 21:54 #226372 by mfgstudio
I understand what I need right now. At first, thanks everyone for fast reply. I was using debian 10 and it has qt5.11.3 inside. I asked my friend who worked with this past years. He said you can do the installation with python2.7 and don't get this errors. I did that and everything is fine now. For now I will go with python2.7 :) I dont wanna waste time on this thing now, when I finish my project, I will try with all the things with latest update.
The following user(s) said Thank You: tommylight, Joco

Please Log in or Create an account to join the conversation.

Moderators: KCJLcvette
Time to create page: 0.080 seconds
Powered by Kunena Forum