Developer Install for Probe Basic Py3 (For UI Development Only)

More
10 Mar 2023 05:11 #266260 by Lcvette
Requirements:
Debian 12 Bookworm (or later)
Linuxcnc 2.9 (or Later)

This is the Development installation for QtPyVCP and Probe Basic:

It is not recommended to run a machine with this installation as it is a run in place inside a virtual environment (venv) as python calls it.  It may run just fine but i have not tested it so have no idea if the venv will introduce any odd latency issues.  This is the new norm for programs installed with pip.  This installation is very simple to install and will set you up with the development tools needed to work on probe basic and contribute through your favorite tool for handing your repositories.

The installation instructions are found here:

github.com/Lcvette/qtpyvcp-bookworm-installer


and follow along video here: 


The following user(s) said Thank You: TurBoss, tommylight, elovalvo, spumco, CNC_ANDI, nwallace, Unlogic

Please Log in or Create an account to join the conversation.

More
10 Mar 2023 05:47 - 10 Mar 2023 05:47 #266263 by rodw
Tested and confirmed its working...
Last edit: 10 Mar 2023 05:47 by rodw.
The following user(s) said Thank You: Lcvette

Please Log in or Create an account to join the conversation.

More
10 Mar 2023 20:24 #266329 by spumco
OMG, that was stupid easy.

Confirmed working on a Win10 Virtualbox VM w/ Bookworm.
The following user(s) said Thank You: Lcvette

Please Log in or Create an account to join the conversation.

More
13 Mar 2023 11:57 - 13 Mar 2023 12:09 #266540 by CNC_ANDI
having error 

File Attachment:

File Name: debug.ini
File Size:52 KB
Attachments:
Last edit: 13 Mar 2023 12:09 by CNC_ANDI.

Please Log in or Create an account to join the conversation.

More
13 Mar 2023 16:27 #266567 by Lcvette
In the development installation, the provided launchers on the desktop must be used.

if you want machine control installation you must use the .deb installation in the sticky thread here:

forum.linuxcnc.org/qtpyvcp/48373-qtpyvcp...llation-files-inside
The following user(s) said Thank You: CNC_ANDI

Please Log in or Create an account to join the conversation.

More
13 Mar 2023 16:33 #266569 by CNC_ANDI
i used the luncher on the desktop... but become this error

Please Log in or Create an account to join the conversation.

More
13 Mar 2023 16:37 #266570 by Lcvette

Please Log in or Create an account to join the conversation.

More
14 Mar 2023 14:03 #266662 by CNC_ANDI
yes using a clean debian bookworm with xfce

Please Log in or Create an account to join the conversation.

More
14 Mar 2023 16:17 #266670 by Lcvette
looks like a conflict here:ERR| vtkShaderProgram (0x64906c0): 0:1(10): error: GLSL 1.50 is not supported. Supported versions are: 1.10, 1.20, and 1.00 ES

you need a graphics card that support GLSL 1.50 or greater

Please Log in or Create an account to join the conversation.

More
14 Mar 2023 17:44 - 14 Mar 2023 18:58 #266679 by CNC_ANDI
ok i will check this... i will put in a pcie graphicscard

edit: Works now fine! Many Thanks you are great!
Last edit: 14 Mar 2023 18:58 by CNC_ANDI.

Please Log in or Create an account to join the conversation.

Moderators: KCJLcvette
Time to create page: 0.302 seconds
Powered by Kunena Forum