User Install for Probe Basic Py3 (For Machine Control)

More
04 Mar 2023 15:07 - 01 May 2023 17:07 #265849 by Lcvette
Official documentation is now available for the USER .deb installation atv the link below:

Probe Basic Installation Instructions Page
Last edit: 01 May 2023 17:07 by Lcvette. Reason: Official Installation docs are now up!
The following user(s) said Thank You: TurBoss, jay.perez1, nwallace

Please Log in or Create an account to join the conversation.

More
04 Mar 2023 20:33 #265868 by rodw
If Debian Bookworm is a prerequsite, perhaps the readme should mention that Linuxcnc is in the Bookworm repositories and can be installed by typing:
sudo apt install linuxcnc-uspace linuxcnc-uspace-dev mesaflash

Note that linuxcnc-uspace-dev is only required if you need some of the developer tools (like halcompile).
mesaflash is only required if you need to manage mesa firmware and bitfiles.
The following user(s) said Thank You: tommylight, Lcvette

Please Log in or Create an account to join the conversation.

More
04 Mar 2023 23:56 #265876 by Lcvette

Please Log in or Create an account to join the conversation.

More
05 Mar 2023 01:00 - 06 Mar 2023 23:28 #265883 by nwallace
EDIT: The issues I encountered have been fixed.
Warning: Spoiler!
Last edit: 06 Mar 2023 23:28 by nwallace. Reason: Updated information

Please Log in or Create an account to join the conversation.

More
05 Mar 2023 01:21 - 05 Mar 2023 01:25 #265887 by rodw

I will preface this by saying that I am about as far as it gets from being an expert in Linux. 

This seemed to be a long winded method of installing Linuxcnc on Bookworm. This may have meant you missed out on some things.
I would start with the Bookworm non-free iso
cdimage.debian.org/cdimage/unofficial/no...onfree/amd64/iso-cd/
I would only use dist-upgrade if I wanted to update from say Bullseye to Bookworm so the commands become
sudo apt update   (this just refreshes the repo index after install)
sudo apt upgrade  (this will bring you up to the current bookworm from the alpha iso released sept 2021)
sudo apt install linuxcnc-uspace linuxcnc-uspace-dev mesaflash (install all the linuxcnc components)
Downgrading to  the 5.10 kernel on Bookworm (now kernel 6.1) makes no sense as that is the kernel included in Bullseye. This probably explains you missing dependencies

Note that there is no need to install the RT kernel as its a dependency of linuxcnc-uspace so it gets installed automatically with linuxcnc.

Finally, the instructions are for Bookworm (Debian 12) and you actually installed on Bullseye (Debian 11)

Unfortunately some of the gnipsel stuff is dated..
Last edit: 05 Mar 2023 01:25 by rodw.

Please Log in or Create an account to join the conversation.

More
05 Mar 2023 01:33 #265888 by nwallace
Forgive my ignorance and simple questions.

Don't we need an rt kernel to run linuxcnc?
I will be using a mesa ethernet card. Do I need to worry about using 5.10 since he says that it works best with? Is he mistaken?

Please Log in or Create an account to join the conversation.

More
05 Mar 2023 01:36 #265890 by rodw
Yes, you do but I updated my answer. It is installed  with linuxcnc-uspace as its a dependency.
But running on the older  Bullseye kernel probabklly broke some things...

Please Log in or Create an account to join the conversation.

More
05 Mar 2023 01:38 #265891 by rodw

 Do I need to worry about using 5.10 since he says that it works best with? Is he mistaken?

Thats his opinion. PCW's opinion is above the 4.x kernel in Buster, the 6.1 and higher kernels are an improvement over thos 5.10 and above

Please Log in or Create an account to join the conversation.

More
05 Mar 2023 02:19 #265893 by Lcvette
The doc is updated, I saw the dependencies missing during a clean test install earlier, you can remove that section of your post if you will as the command in the docs is one line that resolves any all missing dependencies. And I'll update once that's been fixed in the build package.

I also would not recommend to downgrade from 6.1 unless your system experiences issues or you were on bullseye and had significantly better latency. Otherwise I'd stay with 6.1.

Please Log in or Create an account to join the conversation.

More
05 Mar 2023 03:39 #265895 by nwallace
Thanks for all the help.

I just did another fresh install using the non-free alpha 1 iso (I still had to install missing firmware to get the gpu to work) and did an apt update and upgrade which did nothing even though I know there is an alpha 2. I then followed the doc in the google drive and triple checked my work. Probe Basic still will not start. What is the one line that you said fixed it? Do you mean the "sudo apt --fix-broken install" line? I already did that on my earlier attempts in order to get the first 2 packages to install. The python3-probe-basic_0.5.3_all.deb package does not give any dependency errors when you install it. I have not yet fixed it but the first error is about the python module "docopt". I assume if I went and installed all those packages I listed it would work.

Please Log in or Create an account to join the conversation.

Moderators: KCJLcvette
Time to create page: 0.103 seconds
Powered by Kunena Forum