Trouble installing QtPyVCP

More
19 Jul 2023 02:03 #275781 by BigPines
I am trying to install Probe_basic. I tried using this tutorial but it looks like it is old and no longer applicable:


Following the instructions from kcjengr.github.io/probe_basic/quick_start_apt.html lands me at this error:

$ sudo apt install python3-qtpyvcp
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 python3-qtpyvcp : Depends: python3-vtk9 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Any help appreciated.

Please Log in or Create an account to join the conversation.

More
19 Jul 2023 02:06 #275782 by BigPines
Replied by BigPines on topic Trouble installing QtPyVCP
BTW, I installed LinuxCNC using the latest live iso www.linuxcnc.org/iso/linuxcnc-2.8.4-buster.iso

Basic install. Updated and upgraded.

Please Log in or Create an account to join the conversation.

More
19 Jul 2023 07:56 - 19 Jul 2023 07:57 #275798 by Joco
Replied by Joco on topic Trouble installing QtPyVCP
I would recommend:
a. installing Debian 12 from from this list of live iso's:  cdimage.debian.org/debian-cd/current-live/amd64/iso-hybrid/
pick the Xfce version:  cdimage.debian.org/debian-cd/current-liv...2.0.0-amd64-xfce.iso

b. Install linuxcnc from the apt repo per standard documentation (not qtpyvcp specific) for installing linuxcnc on to Debian 12.

c. on the basis  you just want to use Probe Basic and not develop on it then follow these instructions:
www.qtpyvcp.com/install/apt_install.html

Cheers - James.
Last edit: 19 Jul 2023 07:57 by Joco.

Please Log in or Create an account to join the conversation.

More
19 Jul 2023 14:29 - 19 Jul 2023 14:30 #275820 by Lcvette
Replied by Lcvette on topic Trouble installing QtPyVCP
Yup as joco stated and as listed in the requirements,  it requires Debian 12, follow all of the instructions on that page to the letter and should work as expected!
Last edit: 19 Jul 2023 14:30 by Lcvette.

Please Log in or Create an account to join the conversation.

Moderators: KCJLcvette
Time to create page: 0.090 seconds
Powered by Kunena Forum