QtPyVCP - First VCP tutorial problems

More
05 Mar 2024 04:30 #295190 by spumco
I've been fiddling with Probe Basic for a while but I'd like to try a new VCP from scratch.  Sadly, I'm having problems following the tutorial on the qtpyvcp instruction site.

Note: this is a VM installation which followed the PB dev install script

I followed the Clone and Prepare page and everything seemed to go ok... until I tried to start the new vcp (editvcp vcp1).

A new 'vcp1' folder was created, as well as a vcp1 config in the linuxcnc folder, but neither will start.

(venv) lathe@lathe:~$ editvcp vcp1
[EditVCP][INFO]  Logging to /home/lathe/qtpyvcp.log (logger.py:117)
[EditVCP][ERROR]  No valid file type selected.

                  File must be a .yaml config file or a .ui file. (editvcp.py:185)
(venv) lathe@lathe:~$

No vcp1.ui or .yaml file was created.  There is a mainwindow.py file and a mainwindow.ui file under the /vcp1/src/ui folder.

If I run the 'Designer for PB Mill' launcher everything goes just fine.  Qt Designer opens, widget rules and all the qtpyvcp plugin stuff is present.

Any idea what I did wrong?

Attached screenshot of the folder(s) and files created during the installation attempt in case it helps
Attachments:

Please Log in or Create an account to join the conversation.

More
06 Apr 2024 16:23 #297696 by Lcvette
if you look at the probe basic launchers it will show you it is actually calling up scripts to launch everything needed, you could put your fil in the dev folder and mimic the launchers of PB but change the file names to match your new vcp1. this should give you an easy way to launch eveyrthing needed. the venv requirement really made things toublesome..grrr
The following user(s) said Thank You: spumco

Please Log in or Create an account to join the conversation.

Moderators: KCJLcvette
Time to create page: 0.356 seconds
Powered by Kunena Forum