"iocontrol.0.user-enable-out" seems broken in latest 2.9 master

More
08 Nov 2022 17:30 #256220 by turbostew
I updated my 6 or so month old 2.9 master to the latest master a couple days ago and my machine would not get out of ESTOP.  I tracked it down to "iocontrol.0.user-enable-out" never going true.  I am using the qtDragon screen if that is even relevant.  I worked around it using "motion.motion-enabled" in place of "iocontrol.0.user-enable-out".  Any ideas????

Please Log in or Create an account to join the conversation.

More
09 Nov 2022 08:49 #256270 by HansU
It seems more lile a QtDragon thing, so maybe better move this to User Interfaces -> Qtvcp ?

Please Log in or Create an account to join the conversation.

More
09 Nov 2022 18:00 #256301 by cmorley
Can you post your conf files?

Please Log in or Create an account to join the conversation.

More
14 Nov 2022 22:28 #256733 by turbostew
do you mean hal and ini?

Please Log in or Create an account to join the conversation.

More
15 Nov 2022 02:06 #256749 by cmorley
yes, sorry configuration files.

Please Log in or Create an account to join the conversation.

More
18 Nov 2022 05:19 #257007 by turbostew
Attachments:

Please Log in or Create an account to join the conversation.

More
18 Nov 2022 19:38 #257055 by cmorley
How did you decide iocontrol.0.user-enable-out is not working?
I checked on the sim configs and it seems to work.
I don't see anything in the HAL file - other then you need an external input to complete the estop loop.

Please Log in or Create an account to join the conversation.

More
18 Nov 2022 20:55 #257067 by turbostew
Well, it never goes True. It did from master 6 months ago. I also notice that the ESTOP soft button is alway green in the middle, it used to toggle. I wonder if an external estop cycle is needed to "enable" the iocontrol.0.user-enable-out? My external estop shuts down drives and other stuff so not easily tested.

Please Log in or Create an account to join the conversation.

More
18 Nov 2022 21:12 #257069 by cmorley
Ahh I think I see the problem.
If the external estop input is high (clear) at start up it wont let you clear the GUI estop.

While I was testing, the external signal started low so i didn't see this.
Ok let me look into this.

And yes the behavior changed a while back to more closely follow AXIS's behavior.

Please Log in or Create an account to join the conversation.

More
18 Nov 2022 22:12 - 18 Nov 2022 22:13 #257073 by cmorley
ok this behavior is consistent with AXIS so seems an oddity of linuxcnc it's self.

The external enable-in pin can not be in a true state before the GUI estop pin is set true.

iocontrol.0.enable-in will ignore the gui enable-out state (unless connected via HAL)
yet gui enable-out pin will not turn high when linuxcnc is set out of estop by enable-in

Normally the GUI enable-out pin is part of the HAL estop chain, so is _always_ true before the enable-in pin gets set true. This was by design.

So if you can add estop-out to the external estop chain, this will work properly.
Said another was, the GUI button must initiate clearing the external estop chain, before estop-ext is set high.

Chris
Last edit: 18 Nov 2022 22:13 by cmorley.
The following user(s) said Thank You: arvidb

Please Log in or Create an account to join the conversation.

Moderators: cmorley
Time to create page: 0.164 seconds
Powered by Kunena Forum