qtvcp-hd versa probe crashes ui - solved

More
06 May 2023 07:47 - 07 May 2023 13:23 #270773 by zu4lu
Hi, i'm running linuxcnc on bookworm and did the apt install method for linuxcnc. If i choose versaprobe in the ini and click the tab in qtvcp, i get this message and qtvcp-hd exit  .


thanks, Michael
Attachments:
Last edit: 07 May 2023 13:23 by zu4lu.

Please Log in or Create an account to join the conversation.

More
06 May 2023 09:00 #270777 by cmorley
hmm I thought I got all those fixed - maybe the repo is behind.
I will try to find a system here that shows it.

Please Log in or Create an account to join the conversation.

More
06 May 2023 09:01 #270778 by zu4lu
it is the same with the linuxcnc-dev repo

Please Log in or Create an account to join the conversation.

More
06 May 2023 11:18 #270786 by rodw
The Bookworm apt image is a snapshot well behind with the development Chris has done.
Download the latest linuxcnc-uspace Deb file from here 
buildbot2.highlab.com/

sudo apt remove linuxcnc-uspace
sudo dpkg -i  linuxcnc-uspace(tab)

I have not encountered any errors on the eprobing screens this week and Chris has pushed updates several times. See how you go and report back.. 
 

Please Log in or Create an account to join the conversation.

More
06 May 2023 11:35 #270788 by zu4lu
Thanks, but i have now (intel graphic):
Attachments:

Please Log in or Create an account to join the conversation.

More
06 May 2023 11:36 #270789 by zu4lu
installed linuxcnc-uspace_2.9.0~pre1.759.gcccb41f97_amd64.deb

Please Log in or Create an account to join the conversation.

More
06 May 2023 12:30 #270791 by rodw
That looks right. report back if you have issues.

There is only one unresolved  issue I found with probing which was on the basic probe tab. It's currently using the x/y distance instead of the Z distance when probing the Z axis for the surface. Versby currently only as one distance variable for all axes so it's unaffected.

Chris has a test branch I have been testing for him since this morning​​​​​ so it should get to that buildbot in the next couple of days after a couple more tests. Follow this thread forum.linuxcnc.org/qtvcp/48995-qtdragon-probing-issues

If you get further errors, be sure to start Linuxcnc from the command line, click through the error window and share the output in the console window. as its more informative.

Please Log in or Create an account to join the conversation.

More
06 May 2023 14:02 #270797 by zu4lu
Here we go....
As additional info, i did an upgrade from bullseye. Maybe i should start with a fresh install.
Attachments:

Please Log in or Create an account to join the conversation.

More
06 May 2023 16:47 #270801 by zu4lu
So i did a fresh install, no change. 2.9 has not the opengl error, but crashes at the versaprobe screen. 2.10 has the opengl error, starts with the retry function and has a "garbage" main window. Crashes also with the versaprobe window.
Fresh bookworm install with an intel onboard grafix chip.

Please Log in or Create an account to join the conversation.

More
06 May 2023 19:23 #270808 by rodw
Thats showing an OpenGL out of memory error so it's not related to probing.
What graphical environment are you using? SOunds like the default gnome desktop
Can you log out and; once back to the logon screen, with the cursor in the password field, click on the gear icon at bottom right and select a Xorg environment? eg gnome on xorg

I always recommend running  xfce. you can install thet with 
sudo apt install tasksel
sudo tasksel
select xtce and continue.

Please Log in or Create an account to join the conversation.

Moderators: cmorley
Time to create page: 0.141 seconds
Powered by Kunena Forum